summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-02-19 21:28:28 -0500
committerJames P. Harvey2019-02-19 21:31:08 -0500
commit673a9fc897273aba1f760b3ab7c8799e4d0de59a (patch)
treecfac58a36df9d708fff340fa45e1809bba74f7ce
downloadaur-tmux-resurrect-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--tmux-resurrect.install17
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfda2e501611
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Feb 20 02:30:57 UTC 2019
+pkgbase = tmux-resurrect-git
+ pkgdesc = Persist tmux environment across system restarts.
+ pkgver = 2.4.0.r93.gc3ffe89
+ pkgrel = 1
+ url = https://github.com/tmux-plugins/tmux-resurrect
+ install = tmux-resurrect.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = tmux
+ depends = bash
+ optdepends = expect: restore.exp script that fully restores tmux environment
+ source = git+https://github.com/tmux-plugins/tmux-resurrect
+ sha256sums = SKIP
+
+pkgname = tmux-resurrect-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..518c78c30b72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: James P. Harvey <jamespharvey20 at gmail dot com>
+pkgname=tmux-resurrect-git
+_pkgname=tmux-resurrect
+pkgver=2.4.0.r93.gc3ffe89
+pkgrel=1
+pkgdesc="Persist tmux environment across system restarts."
+arch=('any')
+url='https://github.com/tmux-plugins/tmux-resurrect'
+install=tmux-resurrect.install
+license=('MIT')
+depends=('tmux' 'bash')
+optdepends=('expect: restore.exp script that fully restores tmux environment')
+makedepends=('git')
+source=("git+https://github.com/tmux-plugins/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//'
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ sed 's|~/.tmux/plugins/tmux-resurrect|/usr/share/tmux-resurrect-git|' -i scripts/restore.exp
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ mkdir "${pkgdir}/usr/share/${pkgname}"
+ cp -r * "${pkgdir}/usr/share/${pkgname}"
+ rm -r "${pkgdir}/usr/share/${pkgname}/"{LICENSE.md,lib,run_tests,tests,video}
+}
diff --git a/tmux-resurrect.install b/tmux-resurrect.install
new file mode 100644
index 000000000000..7c8185f6afb7
--- /dev/null
+++ b/tmux-resurrect.install
@@ -0,0 +1,17 @@
+common() {
+ echo ' * /etc/tmux.conf
+ * ~/.tmux.conf
+
+"run-shell /usr/share/tmux-resurrect-git/resurrect.tmux"'
+}
+
+
+post_install() {
+ echo 'To use tmux-resurrect, add this to the BOTTOM of either your:'
+ common
+}
+
+post_remove() {
+ echo "Don't forget to remove from either your:"
+ common
+}