summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartSte2024-04-11 20:04:49 +0000
committerBartSte2024-04-11 20:04:49 +0000
commit21c325152ca327dded2829ef08989451f4a30d97 (patch)
treeb8ef5ad71a8449850834646571d3dabe11e0a122
downloadaur-21c325152ca327dded2829ef08989451f4a30d97.tar.gz
Update AUR package
-rw-r--r--.SRCINFO14
-rw-r--r--CHANGELOG.md15
-rw-r--r--PKGBUILD20
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b21f5b95067b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tmux-session
+ pkgdesc = Use fzf to manage your tmux sessions
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/BartSte/tmux-session
+ changelog = CHANGELOG.md
+ arch = any
+ license = MIT
+ depends = fzf
+ depends = tmux
+ source = tmux-session::git+https://github.com/BartSte/tmux-session.git
+ md5sums = SKIP
+
+pkgname = tmux-session
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..6637205bfd7f
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,15 @@
+# Changelog - tmux-session
+This document describes the changes that were made to the software for each
+version. The changes are described concisely, to make it comprehensible for the
+user. A change is always categorized based on the following types:
+- Bug: a fault in the software is fixed.
+- Feature: a functionality is added to the program.
+- Improvement: a functionality in the software is improved.
+- Task: a change is made to the repository that has no effect on the source
+code.
+
+# 0.0.1
+- Added support for symlinks
+
+# 0.0.0
+- First release.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..375242cf6832
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: BartSte bartsteensma@outlook.com
+
+pkgname=tmux-session
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Use fzf to manage your tmux sessions"
+arch=('any')
+url="https://github.com/BartSte/tmux-session"
+license=('MIT')
+depends=('fzf' 'tmux')
+source=("$pkgname::git+https://github.com/BartSte/tmux-session.git")
+md5sums=('SKIP')
+changelog="CHANGELOG.md"
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 LICENCE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm755 src/tmux-session "${pkgdir}/usr/local/bin/tmux-session"
+}
+