summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorr6eve2021-09-09 20:48:35 +0900
committerr6eve2021-09-09 20:48:35 +0900
commit4c30dab41cf66e653f08e9f046adf4024a772e3c (patch)
tree288ed8146c120e96b3ae452f2360e58a054194f4
downloadaur-4c30dab41cf66e653f08e9f046adf4024a772e3c.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27c111085c86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmux-tanlog-bin
+ pkgdesc = Save all console outputs into files
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/r6eve/tmux-tanlog
+ arch = x86_64
+ license = Boost
+ depends = tmux
+ depends = zsh
+ provides = tmux-tanlog
+ conflicts = tmux-tanlog
+ source = https://github.com/r6eve/tmux-tanlog/releases/download/1.0.0/tmux-tanlog-x86_64-unknown-linux-musl
+ sha256sums = a024ec1f0f5514cfcaea3debed9fc82abfd32fc4a664daf8d8be078f3a86cf2a
+
+pkgname = tmux-tanlog-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9eed8a1a8047
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+tmux-tanlog-x86_64-unknown-linux-musl
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..955249e70a1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: r6eve <r6eve at acm dot org>
+
+pkgname=tmux-tanlog-bin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Save all console outputs into files'
+arch=('x86_64')
+url='https://github.com/r6eve/tmux-tanlog'
+license=('Boost')
+depends=('tmux' 'zsh')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${url}/releases/download/${pkgver}/${pkgname%-bin}-${CARCH}-unknown-linux-musl")
+sha256sums=('a024ec1f0f5514cfcaea3debed9fc82abfd32fc4a664daf8d8be078f3a86cf2a')
+
+package() {
+ mv "${pkgname%-bin}-${CARCH}-unknown-linux-musl" "${pkgname%-bin}"
+ install -Dm0755 -t "${pkgdir}/usr/bin/" "${pkgname%-bin}"
+}