summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorr6eve2021-09-29 22:25:33 +0900
committerr6eve2021-09-29 22:25:33 +0900
commit9bcac8ad6958df0fc3ca6bc4a72113b1c2d3024a (patch)
treeea682a86341e94212aeaac2a64c8c50b01ed21ad
parent4c30dab41cf66e653f08e9f046adf4024a772e3c (diff)
downloadaur-9bcac8ad6958df0fc3ca6bc4a72113b1c2d3024a.tar.gz
Version 1.0.1
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD9
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27c111085c86..a34db7122119 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tmux-tanlog-bin
pkgdesc = Save all console outputs into files
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://github.com/r6eve/tmux-tanlog
arch = x86_64
@@ -9,7 +9,8 @@ pkgbase = tmux-tanlog-bin
depends = zsh
provides = tmux-tanlog
conflicts = tmux-tanlog
- source = https://github.com/r6eve/tmux-tanlog/releases/download/1.0.0/tmux-tanlog-x86_64-unknown-linux-musl
- sha256sums = a024ec1f0f5514cfcaea3debed9fc82abfd32fc4a664daf8d8be078f3a86cf2a
+ noextract = tmux-tanlog-bin-1.0.1
+ source = tmux-tanlog-bin-1.0.1::https://github.com/r6eve/tmux-tanlog/releases/download/1.0.1/tmux-tanlog-1.0.1-x86_64-unknown-linux-musl
+ sha256sums = fa23c16b70ea3a1ca647067df21a652dbb2e0a57dc337b0d2d44e57105c12682
pkgname = tmux-tanlog-bin
diff --git a/.gitignore b/.gitignore
index 9eed8a1a8047..689072be1b6f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*.pkg.tar.zst
-tmux-tanlog-x86_64-unknown-linux-musl
+tmux-tanlog-bin-*
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 955249e70a1e..3e7e3433df5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: r6eve <r6eve at acm dot org>
pkgname=tmux-tanlog-bin
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc='Save all console outputs into files'
arch=('x86_64')
@@ -10,10 +10,11 @@ license=('Boost')
depends=('tmux' 'zsh')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-source=("${url}/releases/download/${pkgver}/${pkgname%-bin}-${CARCH}-unknown-linux-musl")
-sha256sums=('a024ec1f0f5514cfcaea3debed9fc82abfd32fc4a664daf8d8be078f3a86cf2a')
+source=("${pkgname}-${pkgver}"::"${url}/releases/download/${pkgver}/${pkgname%-bin}-${pkgver}-${CARCH}-unknown-linux-musl")
+noextract=("${pkgname}-${pkgver}")
+sha256sums=('fa23c16b70ea3a1ca647067df21a652dbb2e0a57dc337b0d2d44e57105c12682')
package() {
- mv "${pkgname%-bin}-${CARCH}-unknown-linux-musl" "${pkgname%-bin}"
+ mv "${pkgname}-${pkgver}" "${pkgname%-bin}"
install -Dm0755 -t "${pkgdir}/usr/bin/" "${pkgname%-bin}"
}