summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-04-26 06:14:15 -0700
committerShadowKyogre2016-04-26 06:14:15 -0700
commitf2e92d51db3de6080096273e30af0bdc4f560434 (patch)
tree4fa3ffb032fc31837ae978f6cf786d9d542b9d8f
downloadaur-f2e92d51db3de6080096273e30af0bdc4f560434.tar.gz
First commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD48
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..212bb41a1228
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Apr 26 13:13:33 UTC 2016
+pkgbase = tmux-tcl-git
+ pkgdesc = A terminal multiplexer (with optional TCL scripting)
+ pkgver = 2.2.r48.gf7af299
+ pkgrel = 1
+ url = http://ershov.github.io/tmux
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = ncurses
+ depends = libevent
+ depends = tcl
+ optdepends = libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)
+ provides = tmux
+ conflicts = tmux
+ conflicts = tmux-git
+ source = tmux-tcl::git+https://github.com/ershov/tmux.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 71601bc37fa44e4395580b321963018e
+
+pkgname = tmux-tcl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5401c5d685d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..3ccacc76d874
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+Copyright (c) 2007 Nicholas Marriott <nicm@users.sourceforge.net>
+
+Permission to use, copy, modify, and distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF MIND, USE, DATA OR PROFITS, WHETHER
+IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
+OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22341663e6c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public+aur@gmail.com>
+
+pkgname=tmux-tcl-git
+_gitname=tmux
+pkgver=2.2.r48.gf7af299
+pkgrel=1
+pkgdesc="A terminal multiplexer (with optional TCL scripting)"
+url="http://ershov.github.io/tmux"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('ncurses' 'libevent' 'tcl')
+makedepends=('git')
+optdepends=('libutempter: Record user sessions to utmp and wtmp files (add to depends array and rebuild to enable)')
+#depends+=('libutempter')
+provides=('tmux')
+conflicts=('tmux' 'tmux-git')
+source=('tmux-tcl::git+https://github.com/ershov/tmux.git'
+ 'LICENSE')
+md5sums=('SKIP'
+ '71601bc37fa44e4395580b321963018e')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%%-git}"
+ git describe --long | sed -e 's:\([^-]*-g\):r\1:' -e 's:-:.:g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%%-git}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${pkgname%%-git}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname%%-git}"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/tmux/LICENSE"
+
+ # install example config files
+ install -Dm755 example_tmux.conf "$pkgdir/usr/share/tmux/example_tmux.conf"
+ install -Dm755 example_tcl_tmux.conf "$pkgdir/usr/share/tmux/example_tcl_tmux.conf"
+ install -Dm755 example_tcl_tmux.tcl "$pkgdir/usr/share/tmux/example_tcl_tmux.tcl"
+}