summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-12-28 22:58:51 -0500
committerandalenavals2017-12-28 22:58:51 -0500
commitae11adae2087e38dff6bfe3d7100bc728861744f (patch)
treecc0514b1c3a4e70befe0ec2ceae16fae65e6f04c
downloadaur-ae11adae2087e38dff6bfe3d7100bc728861744f.tar.gz
there are two warning namcamp about not used share libraries
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD56
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e172ae90d8c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tmv-git
+ pkgdesc = A fast, intuitive linear algebra library for C++
+ pkgver = r101.fab5df3
+ pkgrel = 1
+ url = https://github.com/rmjarvis/tmv/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = bash
+ depends = cblas
+ source = tmv-git-r101.fab5df3::git+https://github.com/rmjarvis/tmv/
+ md5sums = SKIP
+
+pkgname = tmv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25e161b6a93b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=tmv-git
+pkgver=r101.fab5df3
+pkgrel=1
+#epoch=
+
+pkgdesc=" A fast, intuitive linear algebra library for C++ "
+
+
+arch=('i686' 'x86_64')
+url="https://github.com/rmjarvis/tmv/"
+license=('BSD')
+groups=()
+depends=('bash' 'cblas')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ scons PREFIX=/usr
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ scons PREFIX=$pkgdir/usr install
+ install -Dm644 TMV_LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+}