summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvuillaume2022-01-31 21:12:39 +0100
committervuillaume2022-01-31 21:12:39 +0100
commit2b827d3e012a5d94481a00cdd92fee48ace0a4e5 (patch)
tree7226ee5406f69c8b456fd469891698638552243e
parent95d4127c35d2724dbb7a7cdb677ed9f2f9319ebe (diff)
downloadaur-tn5250.tar.gz
PKGBUILD update plus compilation patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--tn5250-0.17.4-format.patch39
3 files changed, 48 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e25265945f..2db95402288e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Sun Jul 10 15:11:21 UTC 2016
pkgbase = tn5250
pkgdesc = A 5250 terminal emulator for IBM iSeries and AS400
pkgver = 0.17.4
@@ -11,8 +9,9 @@ pkgbase = tn5250
depends = openssl
source = http://downloads.sourceforge.net/project/tn5250/tn5250/0.17.4/tn5250-0.17.4.tar.gz
source = patch-lib5250_sslstream_c.patch::http://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/ports/net/tn5250/patches/patch-lib5250_sslstream_c
+ source = tn5250-0.17.4-format.patch
sha256sums = 354237d400dc46af887cb3ffa4ed1f2c371f5b8bee8be046a683a4ac9db4f9c5
sha256sums = 87bdd8f6a53442d3c2c7a80385725b63106a96d622d52643cc3cdc2282e1e8f6
+ sha256sums = aead8751833cc5bd8b7999b3e7ff6b907667bd26bf92acee4c5c674de6e2c6a3
pkgname = tn5250
-
diff --git a/PKGBUILD b/PKGBUILD
index e71b8a046201..e7da3a29932a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: yannsen <ynnsen@gmail.com>
-
+# Contributor: vuillaume <vuillaume12@yahoo.com>
pkgname=tn5250
pkgver=0.17.4
pkgrel=7
@@ -10,18 +10,21 @@ url="http://tn5250.sourceforge.net/"
license=('LGPL2.1')
depends=('openssl')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "patch-lib5250_sslstream_c.patch"::"http://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/ports/net/tn5250/patches/patch-lib5250_sslstream_c")
+ "patch-lib5250_sslstream_c.patch"::"http://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/ports/net/tn5250/patches/patch-lib5250_sslstream_c"
+ "tn5250-0.17.4-format.patch")
sha256sums=('354237d400dc46af887cb3ffa4ed1f2c371f5b8bee8be046a683a4ac9db4f9c5'
- '87bdd8f6a53442d3c2c7a80385725b63106a96d622d52643cc3cdc2282e1e8f6')
+ '87bdd8f6a53442d3c2c7a80385725b63106a96d622d52643cc3cdc2282e1e8f6'
+ 'aead8751833cc5bd8b7999b3e7ff6b907667bd26bf92acee4c5c674de6e2c6a3')
prepare() {
cd "${pkgname}-${pkgver}"
patch -p0 -i "${srcdir}/patch-lib5250_sslstream_c.patch"
+ patch -p0 -i "${srcdir}/tn5250-0.17.4-format.patch"
}
build() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ ./configure --with-ssl=/usr/include/openssl
make
}
diff --git a/tn5250-0.17.4-format.patch b/tn5250-0.17.4-format.patch
new file mode 100644
index 000000000000..5742008e316c
--- /dev/null
+++ b/tn5250-0.17.4-format.patch
@@ -0,0 +1,39 @@
+diff -up curses/cursesterm.c.format tn5250-0.17.4/curses/cursesterm.c
+--- curses/cursesterm.c.format 2013-12-03 16:26:11.000000000 +0100
++++ curses/cursesterm.c 2013-12-03 16:26:44.000000000 +0100
+@@ -640,9 +640,9 @@ static void curses_terminal_update(Tn525
+ if(This->data->is_xterm) {
+ if (This->data->font_132!=NULL) {
+ if (tn5250_display_width (display)>100)
+- printf(This->data->font_132);
++ printf("%s",This->data->font_132);
+ else
+- printf(This->data->font_80);
++ printf("%s",This->data->font_80);
+ }
+ printf ("\x1b[8;%d;%dt", tn5250_display_height (display)+1,
+ tn5250_display_width (display));
+diff -up lib5250/sslstream.c.format tn5250-0.17.4/lib5250/sslstream.c
+--- lib5250/sslstream.c.format 2013-12-03 16:23:27.000000000 +0100
++++ lib5250/sslstream.c 2013-12-03 16:24:01.000000000 +0100
+@@ -307,7 +307,7 @@ static void ssl_log_SB_buf(unsigned char
+
+ if (!tn5250_logfile)
+ return;
+- fprintf(tn5250_logfile,ssl_getTelOpt(type=*buf++));
++ fprintf(tn5250_logfile,"%s",ssl_getTelOpt(type=*buf++));
+ switch (c=*buf++) {
+ case IS:
+ fputs("<IS>",tn5250_logfile);
+diff -up lib5250/telnetstr.c.format tn5250-0.17.4/lib5250/telnetstr.c
+--- lib5250/telnetstr.c.format 2013-12-03 16:25:10.000000000 +0100
++++ lib5250/telnetstr.c 2013-12-03 16:25:23.000000000 +0100
+@@ -282,7 +282,7 @@ static void log_SB_buf(unsigned char *bu
+
+ if (!tn5250_logfile)
+ return;
+- fprintf(tn5250_logfile,getTelOpt(type=*buf++));
++ fprintf(tn5250_logfile,"%s",getTelOpt(type=*buf++));
+ switch (c=*buf++) {
+ case IS:
+ fputs("<IS>",tn5250_logfile);