summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Platte2015-06-18 10:59:23 +0200
committerJonas Platte2015-06-18 10:59:23 +0200
commitb17033cb9b5ea89896bb3c25e6818e20cf5b47bb (patch)
tree584b8b9b41f6c179ce660d80e2dd6876f0af69f4
downloadaur-b17033cb9b5ea89896bb3c25e6818e20cf5b47bb.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2ef7c9220eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tntdb-git
+ pkgdesc = A C++ library for easy and robust access of SQL databases
+ pkgver = 1.3.1.3dd171f
+ pkgrel = 1
+ url = http://www.tntnet.org/tntdb.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = cxxtools
+ depends = postgresql-libs
+ depends = libmysqlclient
+ depends = sqlite
+ provides = tntdb
+ conflicts = tntdb
+ source = tntdb-git::git+https://github.com/maekitalo/tntdb.git
+ sha256sums = SKIP
+
+pkgname = tntdb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..758149e98547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jonas Platte <aur@jonasplatte.de>
+
+pkgname=tntdb-git
+pkgver=1.3.1.3dd171f
+pkgrel=1
+pkgdesc="A C++ library for easy and robust access of SQL databases"
+arch=('i686' 'x86_64')
+url="http://www.tntnet.org/tntdb.html"
+license=('LGPL')
+depends=('cxxtools' 'postgresql-libs' 'libmysqlclient' 'sqlite')
+makedepends=('git')
+provides=('tntdb')
+conflicts=('tntdb')
+source=("$pkgname::git+https://github.com/maekitalo/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+# This will very likely break if tntdb starts using tags. That is intentional,
+# as the --always will be removed then anyway, requiring an update
+pkgver() {
+ cd "$pkgname"
+ echo "1.3.1.$(git describe --always)"
+}
+
+build() {
+ cd "$pkgname"
+
+ autoreconf -i
+ ./configure --enable-silent-rules --prefix=/usr
+ make
+}
+
+# currently broken
+#check() {
+# cd "$pkgname"
+#
+# ./test/tntdb-test
+#}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}