summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Reimer2015-08-10 13:30:18 +0200
committerChristopher Reimer2015-08-10 13:30:18 +0200
commit41d933acbdc7cb5d102d4aceb837619d40429ee4 (patch)
treee18cb10d6593f33f726e9f4018a028e217b15671
downloadaur-41d933acbdc7cb5d102d4aceb837619d40429ee4.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/7f69ddab9523aff9d6ed3ca4c5b511d9ad07e879)
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d295f0c1c017
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tntnet
+ pkgdesc = Modular, multithreaded, high performance webapplicationserver for C++
+ pkgver = 2.2.1
+ pkgrel = 1
+ url = http://www.tntnet.org
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ depends = cxxtools
+ depends = openssl
+ depends = zlib
+ source = http://www.tntnet.org/download/tntnet-2.2.1.tar.gz
+ md5sums = febe799675c1b8b2f7259bad30cf6f23
+
+pkgname = tntnet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cea682c75752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
+pkgname=tntnet
+pkgver=2.2.1
+pkgrel=1
+pkgdesc="Modular, multithreaded, high performance webapplicationserver for C++"
+url="http://www.tntnet.org"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('cxxtools' 'openssl' 'zlib')
+source=("http://www.tntnet.org/download/${pkgname}-${pkgver}.tar.gz")
+md5sums=('febe799675c1b8b2f7259bad30cf6f23')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-unittest \
+ --with-demos=no \
+ --with-server=no
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+}