summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2021-12-20 19:31:44 +0100
committerManuel Reimer2021-12-20 19:31:44 +0100
commit9899ab9f8cb3cb55032f14d8ee71b8da834dbaf2 (patch)
tree45330230716070cf02d07b181cbf415102ffa04d
parent70b16bd61368ea7b7bec9f92d8d634ed58b2433b (diff)
downloadaur-9899ab9f8cb3cb55032f14d8ee71b8da834dbaf2.tar.gz
Sync from VDR4Arch (https://github.com/VDR4Arch/vdr4arch/commit/0c5a77764be1c621c18a65b3f0ad3e3526c474dc)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b0b2834dcd2..ffeabe1dc3e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by makepkg 6.0.1
-# Sat Sep 11 11:15:56 UTC 2021
+# Mon Dec 20 18:31:43 UTC 2021
pkgbase = tntnet
pkgdesc = Modular, multithreaded, high performance webapplicationserver for C++
pkgver = 3.0
@@ -15,7 +15,9 @@ pkgbase = tntnet
depends = openssl
depends = zlib
depends = perl
- source = http://www.tntnet.org/download/tntnet-3.0.tar.gz
- sha256sums = 718e5519b0a403f7f766358bf66a85c008119c48189d1c2b7651fd0af9018e27
+ source = tntnet-3.0_git.tar.gz::https://github.com/maekitalo/tntnet/archive/refs/tags/V3.0.tar.gz
+ source = tntnet-autoconf-2.70-fixes.patch::https://github.com/maekitalo/tntnet/commit/69adfc8ee351a0e82990c1ffa7af6dab726e1e49.patch
+ sha256sums = bc16249f7af7c7b407ec37bb397fe1eb8b54d2410dd5208531ca58908fc19f48
+ sha256sums = 401573b47d74348d065a9a83af0428525bcb90d88142e02c0d647ec10bb3f9df
pkgname = tntnet
diff --git a/PKGBUILD b/PKGBUILD
index 6dcf6a796aec..9823879be7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,24 @@ url="http://www.tntnet.org"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
depends=('cxxtools' 'openssl' 'zlib' 'perl')
-source=("http://www.tntnet.org/download/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('718e5519b0a403f7f766358bf66a85c008119c48189d1c2b7651fd0af9018e27')
+source=("$pkgname-${pkgver}_git.tar.gz::https://github.com/maekitalo/tntnet/archive/refs/tags/V${pkgver}.tar.gz"
+ "$pkgname-autoconf-2.70-fixes.patch::https://github.com/maekitalo/tntnet/commit/69adfc8ee351a0e82990c1ffa7af6dab726e1e49.patch")
+sha256sums=('bc16249f7af7c7b407ec37bb397fe1eb8b54d2410dd5208531ca58908fc19f48'
+ '401573b47d74348d065a9a83af0428525bcb90d88142e02c0d647ec10bb3f9df')
+
+prepare() {
+ # autoconf-2.70 fixes
+ patch -d "$pkgname-$pkgver" -p1 -i "../$pkgname-autoconf-2.70-fixes.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -i
./configure --prefix=/usr \
- --disable-static \
+ --sysconfdir=/etc \
--disable-unittest \
- --with-demos=no \
- --with-server=no
+ --without-demos \
+ --without-server
make
}