summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohnathan Jenkins2017-11-07 10:15:35 -0800
committerJohnathan Jenkins2017-11-07 10:15:35 -0800
commit08c3be7e73cf33c9990aa2c871e08f0059b44a04 (patch)
treea5be738a436f0e56d5a33bf1ba1f9261ec9cd0b9
parentb94f017183d54b9a5443d086b97565f7440c7ea5 (diff)
downloadaur-08c3be7e73cf33c9990aa2c871e08f0059b44a04.tar.gz
update and add zsh functions
-rwxr-xr-x[-rw-r--r--].SRCINFO0
-rwxr-xr-x[-rw-r--r--]PKGBUILD8
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf282c1810fe..cf282c1810fe 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 70daec6e9431..eb2eac8dd0c0 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
pkgname=todoist
-pkgver=0.9.1
-pkgrel=2
+pkgver=0.9.2
+pkgrel=1
pkgdesc="Todoist CLI Client, written in Golang."
arch=('x86_64' 'i686')
url="https://github.com/sachaos/todoist"
license=('MIT')
makedepends=('go' 'git')
+optdepends=('peco: for zsh functions script')
options=('!strip' '!emptydirs')
source=("https://github.com/sachaos/todoist/archive/v$pkgver.tar.gz")
-sha256sums=('2986fffe561847d5f40740a1455568e8fb8e4e0409418738fe7d8445250781a7')
+sha256sums=('e4ad00b64bba61d199de3dff12095fde71bca2b32b8a14ff83189b5cfb2d2e54')
prepare() {
mkdir -p "$srcdir/go"
@@ -28,6 +29,7 @@ package() {
cd $srcdir/$pkgname-$pkgver
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
cd "$srcdir/$pkgname-$pkgver"
+ install -Dm644 todoist_functions.sh "${pkgdir}/usr/share/todoist/todoist_functions.sh"
mkdir -p $pkgdir/usr/share/licenses/$pkgname
install -m 0644 LICENSE $pkgdir/usr/share/licenses/$pkgname/
rm -r "$srcdir/go"