summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaksim Novikov2020-03-01 14:37:21 +0100
committerMaksim Novikov2020-03-01 14:37:21 +0100
commit05064e2dab5c6cfe5dbbef7620e4294985c0953d (patch)
treea5dd966ce6856b3091b83a4ae4075e2c2a530134
parent82252044fca61f55c2d1513270b936e39c2fbe31 (diff)
downloadaur-05064e2dab5c6cfe5dbbef7620e4294985c0953d.tar.gz
Install fzf scripts
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfcae8957014..d19024c9f9d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = todoist-git
pkgdesc = Todoist CLI Client, written in Golang.
- pkgver = r267.49fb10b
+ pkgver = r281.8633222
pkgrel = 1
url = https://github.com/sachaos/todoist
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 59a9d21a7fb1..60f619f76c81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Maksim Novikov <mnovikov.work@gmail.com>
# Contributor: David Roizenman <david@hmnd.io>
# Contributor: Thor K. Høgås <thor at roht no>
+# Contributor: Austin Keller
_pkgname=todoist
pkgname=${_pkgname}-git
-pkgver=r267.49fb10b
+pkgver=r281.8633222
pkgrel=1
pkgdesc="Todoist CLI Client, written in Golang."
arch=('x86_64' 'i686')
@@ -37,12 +38,14 @@ build() {
export GO111MODULE="on"
cd "$srcdir/go/src/github.com/sachaos/$_pkgname"
make install
+ chmod u+w -R "$GOPATH"
}
package() {
install -Dm755 "$srcdir/go/bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
cd "$srcdir/go/src/github.com/sachaos/$_pkgname"
install -Dm644 todoist_functions.sh "${pkgdir}/usr/share/todoist/todoist_functions.sh"
+ install -Dm644 todoist_functions_fzf.sh "${pkgdir}/usr/share/todoist/todoist_functions_fzf.sh"
mkdir -p "$pkgdir/usr/share/licenses/$_pkgname"
install -m 0644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/"
}