summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2017-09-03 13:35:08 -0300
committerHugo Osvaldo Barrera2017-09-03 13:35:08 -0300
commitc81af0e63a2a1e4b128736cbfae8e6d94bdb0f0b (patch)
treea47d1b38f387a08bf0a1c8a53971eb6ea89ce169
parentd9a255d4734e094c3bac82da9e76f0fb5c169d05 (diff)
downloadaur-c81af0e63a2a1e4b128736cbfae8e6d94bdb0f0b.tar.gz
Skip tests if pyicu is installed
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d34c5326a70..85c25d9d0706 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,9 @@ build() {
check() {
cd "$srcdir/$pkgname-$pkgver"
+ # Skip tests if pyicu is installed, since it makes tests fail:
+ python -c "import icu" 2> /dev/null || return
+
export PYTHONPATH="${PYTHONPATH%:}:${PWD}"
export TZ=UTC
sed -i '/addopts/d' "$srcdir"/"$pkgname-$pkgver"/setup.cfg