summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2016-04-17 16:10:57 -0300
committerHugo Osvaldo Barrera2016-04-17 16:10:57 -0300
commitfa108e719030ec9a34e9b4bc9ef337a689a977e5 (patch)
treee285b65404569e1f1667d68582bba2bb6a825e8d
parent9490c510e9bf7378dbc939c9e79c63b0a55ef29d (diff)
downloadaur-fa108e719030ec9a34e9b4bc9ef337a689a977e5.tar.gz
Implement check()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f338a248a56..6b7a2b38d9e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = todoman
url = https://github.com/pimutils/todoman
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-hypothesis
depends = python-icalendar
depends = python-urwid
depends = python-xdg
diff --git a/PKGBUILD b/PKGBUILD
index 4874ef8bd4bc..4910a655d23a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ depends=(python-icalendar python-urwid python-xdg python-ansi
python-parsedatetime python-atomicwrites python-click
python-setuptools-scm)
optdepends=('python-click-repl-git: the repl command.')
+checkdepends=('python-pytest' 'python-hypothesis')
source=("https://pypi.python.org/packages/source/t/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('ef411ddfee02c2261e124af15699cac2')
@@ -20,6 +21,13 @@ build() {
python setup.py build
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ export PYTHONPATH=$(pwd)
+ py.test
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"