summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2018-05-12 13:02:06 -0300
committerHugo Osvaldo Barrera2018-05-12 13:02:06 -0300
commit06ce21f4c946947cf34034aa67cec6d07048df71 (patch)
tree6029dcf2ec2f6a5be3ed121fbff4bdfde8433ff3
parentdadef55f36a2008fde5da87afe7423a021e3a709 (diff)
downloadaur-06ce21f4c946947cf34034aa67cec6d07048df71.tar.gz
Install zsh autocompletions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15cbf00beec2..f18b0e7323ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 6 23:03:52 UTC 2018
+# Sat May 12 16:01:40 UTC 2018
pkgbase = todoman-git
pkgdesc = A simple CalDav-based todo manager.
- pkgver = 3.2.3.post21+gdc64bbd
+ pkgver = 3.3.0.post16+g9043aff
pkgrel = 1
url = https://github.com/pimutils/todoman
arch = any
@@ -25,6 +25,7 @@ pkgbase = todoman-git
depends = python-humanize
optdepends = python-click-repl: the repl command.
optdepends = bash-completion: bash autocompletion.
+ optdepends = zsh-completions: zsh autocompletion.
provides = todoman
conflicts = todoman
source = git+https://github.com/pimutils/todoman.git
diff --git a/PKGBUILD b/PKGBUILD
index 297ebe4e5def..0cd640dabcd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=todoman-git
_pkgname=todoman
-pkgver=3.2.3.post21+gdc64bbd
+pkgver=3.4.0
pkgrel=1
pkgdesc="A simple CalDav-based todo manager."
arch=("any")
@@ -12,7 +12,8 @@ depends=(python-icalendar python-urwid python-xdg python-parsedatetime
python-atomicwrites python-click python-setuptools-scm
python-configobj python-dateutil python-tabulate python-humanize)
optdepends=('python-click-repl: the repl command.'
- 'bash-completion: bash autocompletion.')
+ 'bash-completion: bash autocompletion.'
+ 'zsh-completions: zsh autocompletion.')
checkdepends=('python-pytest' 'python-hypothesis' 'python-pytest-runner'
'python-freezegun' 'python-pytest-cov')
conflicts=("todoman")
@@ -48,4 +49,7 @@ package() {
install -Dm 644 contrib/completion/bash/_todo \
"$pkgdir/usr/share/bash-completion/completions/todo"
+
+ install -Dm 644 contrib/completion/zsh/_todo \
+ "$pkgdir/usr/share/zsh/site-functions/_todo"
}