summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2018-05-06 20:03:56 -0300
committerHugo Osvaldo Barrera2018-05-06 20:03:56 -0300
commitdadef55f36a2008fde5da87afe7423a021e3a709 (patch)
treef610bfb2ae04c64a50c7133fe9498824f48f1ae0
parent91aa917665d38c8b329dab9751558317c0b1eaa4 (diff)
downloadaur-dadef55f36a2008fde5da87afe7423a021e3a709.tar.gz
Copy over tweaks from `todoman` package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39077ff78e5a..15cbf00beec2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
# Generated by mksrcinfo v8
-# Tue Jan 2 13:00:10 UTC 2018
+# Sun May 6 23:03:52 UTC 2018
pkgbase = todoman-git
pkgdesc = A simple CalDav-based todo manager.
pkgver = 3.2.3.post21+gdc64bbd
pkgrel = 1
url = https://github.com/pimutils/todoman
arch = any
- license = MIT
+ license = ISC
checkdepends = python-pytest
checkdepends = python-hypothesis
checkdepends = python-pytest-runner
@@ -23,7 +23,8 @@ pkgbase = todoman-git
depends = python-dateutil
depends = python-tabulate
depends = python-humanize
- optdepends = python-click-repl-git: the repl command.
+ optdepends = python-click-repl: the repl command.
+ optdepends = bash-completion: bash autocompletion.
provides = todoman
conflicts = todoman
source = git+https://github.com/pimutils/todoman.git
diff --git a/PKGBUILD b/PKGBUILD
index 348a9c803716..297ebe4e5def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,12 @@ pkgrel=1
pkgdesc="A simple CalDav-based todo manager."
arch=("any")
url="https://github.com/pimutils/todoman"
-license=('MIT')
+license=('ISC')
depends=(python-icalendar python-urwid python-xdg python-parsedatetime
python-atomicwrites python-click python-setuptools-scm
python-configobj python-dateutil python-tabulate python-humanize)
-optdepends=('python-click-repl-git: the repl command.')
+optdepends=('python-click-repl: the repl command.'
+ 'bash-completion: bash autocompletion.')
checkdepends=('python-pytest' 'python-hypothesis' 'python-pytest-runner'
'python-freezegun' 'python-pytest-cov')
conflicts=("todoman")
@@ -44,4 +45,7 @@ package() {
"$pkgdir/usr/share/doc/todoman/examples/todoman.conf"
install -Dm 755 bin/todo "$pkgdir/usr/bin/todo"
+
+ install -Dm 644 contrib/completion/bash/_todo \
+ "$pkgdir/usr/share/bash-completion/completions/todo"
}