summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Jones2022-06-26 09:28:54 +0100
committerPhil Jones2022-06-26 09:28:54 +0100
commitaa670b68a7f0850270661d06a37759d3474fe4eb (patch)
tree5bc842be49c3301dff0fbc6ecdf4da1ca49facd1
downloadaur-aa670b68a7f0850270661d06a37759d3474fe4eb.tar.gz
Initial package creation.
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90326db1dcf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = tofi-git
+ pkgdesc = Tiny rofi / dmenu replacement for wlroots-based Wayland compositors.
+ pkgver = r73.32e2cb8
+ pkgrel = 1
+ url = https://github.com/philj56/tofi
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ makedepends = scdoc
+ makedepends = wayland-protocols
+ depends = freetype2
+ depends = harfbuzz
+ depends = cairo
+ depends = pango
+ depends = wayland
+ depends = libxkbcommon
+ provides = tofi
+ conflicts = tofi
+ source = tofi-git::git+https://github.com/philj56/tofi
+ sha512sums = SKIP
+
+pkgname = tofi-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aabcccf7c34f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Philip Jones <philj56@gmail.com>
+pkgname=tofi-git
+pkgver=r73.32e2cb8
+pkgrel=1
+pkgdesc="Tiny rofi / dmenu replacement for wlroots-based Wayland compositors."
+arch=("x86_64")
+url="https://github.com/philj56/tofi"
+license=("MIT")
+groups=()
+depends=("freetype2" "harfbuzz" "cairo" "pango" "wayland" "libxkbcommon")
+makedepends=("meson" "git" "scdoc" "wayland-protocols")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+${url}")
+noextract=()
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname}"
+ meson --prefix /usr -Dbuildtype=release build
+}
+
+build() {
+ cd "${pkgname}"
+ ninja -C build
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="$pkgdir" ninja -C build install
+}