summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2017-05-18 10:07:46 +0930
committerSamuel Walladge2017-05-18 10:07:46 +0930
commita07a7f74e5d6303d407c43b90d3445393dec5abc (patch)
treeb00e0d38ac51fabe6e62a8b7adcca778c60b5750
parent61a3191c936fed83ecc5c61b63cbb8c9083500f7 (diff)
downloadaur-a07a7f74e5d6303d407c43b90d3445393dec5abc.tar.gz
bump version to 7.4.38
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--production.patch9
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e8842480ca1..62531e59b3b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 24 10:46:34 UTC 2017
+# Thu May 18 00:37:16 UTC 2017
pkgbase = toggldesktop
pkgdesc = Toggl time tracking software
- pkgver = 7.4.24
+ pkgver = 7.4.38
pkgrel = 1
url = https://github.com/toggl/toggldesktop
arch = x86_64
@@ -21,10 +21,10 @@ pkgbase = toggldesktop
depends = qt5-x11extras
conflicts = toggldesktop-bin
conflicts = toggl-bin
- source = toggldesktop-7.4.24.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.24.tar.gz
+ source = toggldesktop-7.4.38.tar.gz::https://github.com/toggl/toggldesktop/archive/v7.4.38.tar.gz
source = production.patch
- sha512sums = 3763f44a7364e130600edb09052132e0eef2f7d4700b661d20b0f5bdc4844504af186ce8aefc7953efb4ea9374883bad83f2e080c8f3eedc93533cff3bd0f108
- sha512sums = b694b38cf9ab0391dc6b1fc7a7e0dccf910e1edd16389d9eb8b2a893df1fddb86e6eb212bebdf008c8ec6991dc05f3dac6996ba2aa570211cd68f503879cadaa
+ sha512sums = be1f8809cc3c1020fe6eba60b50d85b12f18e4490b8d311f406a49d936a4568676bb98629d7f91946bdfd99a4a60c78a55f8c9b1c045e6bd9d0f3dce323dd472
+ sha512sums = 484c6e3ba73e2f2ccbe9737424bee68624bd8d46a06735937b3ca134aa34ad9e335b260f7d22bcd3e351ae9d8b989ef048e78cf7ed52bac363bb651a7d229428
pkgname = toggldesktop
diff --git a/PKGBUILD b/PKGBUILD
index 964e35ab1999..9aef9f844394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Karel Louwagie <karel@louwagie.net>
pkgname=toggldesktop
-pkgver=7.4.24
+pkgver=7.4.38
pkgrel=1
pkgdesc="Toggl time tracking software"
arch=('x86_64')
@@ -23,8 +23,8 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/toggl/toggldesktop/arch
"production.patch"
)
-sha512sums=('3763f44a7364e130600edb09052132e0eef2f7d4700b661d20b0f5bdc4844504af186ce8aefc7953efb4ea9374883bad83f2e080c8f3eedc93533cff3bd0f108'
- 'b694b38cf9ab0391dc6b1fc7a7e0dccf910e1edd16389d9eb8b2a893df1fddb86e6eb212bebdf008c8ec6991dc05f3dac6996ba2aa570211cd68f503879cadaa')
+sha512sums=('be1f8809cc3c1020fe6eba60b50d85b12f18e4490b8d311f406a49d936a4568676bb98629d7f91946bdfd99a4a60c78a55f8c9b1c045e6bd9d0f3dce323dd472'
+ '484c6e3ba73e2f2ccbe9737424bee68624bd8d46a06735937b3ca134aa34ad9e335b260f7d22bcd3e351ae9d8b989ef048e78cf7ed52bac363bb651a7d229428')
conflicts=('toggldesktop-bin' 'toggl-bin')
diff --git a/production.patch b/production.patch
index cc70d986a4db..561787deb12c 100644
--- a/production.patch
+++ b/production.patch
@@ -1,5 +1,5 @@
diff --git a/src/context.cc b/src/context.cc
-index f47a23c13..45d169056 100644
+index cecc136b0..df6f43288 100644
--- a/src/context.cc
+++ b/src/context.cc
@@ -76,7 +76,7 @@ Context::Context(const std::string app_name, const std::string app_version)
@@ -8,19 +8,18 @@ index f47a23c13..45d169056 100644
, sync_interval_seconds_(0)
-, update_check_disabled_(false)
+, update_check_disabled_(true)
+ , had_something_to_push_(false)
, quit_(false)
, ui_updater_(this, &Context::uiUpdaterActivity)
- , reminder_(this, &Context::reminderActivity)
-@@ -88,9 +88,6 @@ Context::Context(const std::string app_name, const std::string app_version)
+@@ -90,8 +90,6 @@ Context::Context(const std::string app_name, const std::string app_version)
Poco::Net::HTTPSStreamFactory::registerFactory();
}
- urls::SetUseStagingAsBackend(
- app_version.find("7.0.0") != std::string::npos);
--
+
Poco::ErrorHandler::set(&error_handler_);
Poco::Net::initializeSSL();
-
diff --git a/src/ui/linux/TogglDesktop/TogglDesktop.pro b/src/ui/linux/TogglDesktop/TogglDesktop.pro
index bf49aaa41..cc6b6a4ef 100644
--- a/src/ui/linux/TogglDesktop/TogglDesktop.pro