summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValérie Roux2023-11-03 00:16:35 +0100
committerValérie Roux2023-11-03 00:16:35 +0100
commit064db7dd1f280b291f84529db147d0b1a919ec13 (patch)
treecaa4f6b274912dc99a1c68166a09407860ad14cf
downloadaur-064db7dd1f280b291f84529db147d0b1a919ec13.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
-rw-r--r--fix-build.patch22
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74db2605c96a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = toggle-git
+ pkgdesc = Like Tweaks, but with more libadwaita!
+ pkgver = r101.4eda274
+ pkgrel = 1
+ url = https://gitlab.com/OroWith2Os/toggle
+ arch = any
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = blueprint-compiler
+ makedepends = git
+ makedepends = meson
+ makedepends = typescript
+ depends = libadwaita
+ depends = gjs
+ depends = gnome-shell
+ source = git+https://gitlab.com/OroWith2Os/toggle
+ source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions
+ source = fix-build.patch
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = e8f69a7f9e789251ef7e5060e1c681bbc1806371021f3bc1abf66fadb4dd48535c9e270cf9bf64beb9b6d67d469bc1c92526f9cec81baa2ac50e0862d53c2215
+
+pkgname = toggle-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b0db289de7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+_name=toggle
+pkgname=toggle-git
+pkgver=r101.4eda274
+pkgrel=1
+pkgdesc="Like Tweaks, but with more libadwaita!"
+arch=('any')
+url="https://gitlab.com/OroWith2Os/$_name"
+license=('GPL3')
+depends=('libadwaita' 'gjs' 'gnome-shell')
+makedepends=('blueprint-compiler' 'git' 'meson' 'typescript')
+checkdepends=('appstream-glib')
+source=("git+https://gitlab.com/OroWith2Os/$_name"
+ "git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions"
+ "fix-build.patch")
+b2sums=('SKIP'
+ 'SKIP'
+ 'e8f69a7f9e789251ef7e5060e1c681bbc1806371021f3bc1abf66fadb4dd48535c9e270cf9bf64beb9b6d67d469bc1c92526f9cec81baa2ac50e0862d53c2215')
+
+pkgver() {
+ cd "$_name"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+prepare() {
+ cd $_name
+ git submodule init
+ git config submodule.src/gi-types.url "$srcdir/gi-typescript-definitions"
+ git -c protocol.file.allow=always submodule update
+ patch --forward --strip=1 --input="${srcdir}/fix-build.patch"
+}
+
+
+build() {
+ cd $_name
+ arch-meson ../$_name ../build
+ meson compile -C ../build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..dce07dc24f69
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,22 @@
+diff --git a/src/meson.build b/src/meson.build
+index 172c191dbffe4f84f9a7c3acb19e6b67b873569d..6cb6090763f7ad6af6b4ec0c7f1226633279501f 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -28,7 +28,7 @@ sources = files(
+ 'warning.ts',
+ 'window.ts',
+ )
+-
++tsc_in = meson.project_source_root()
+ tsc_out = meson.project_build_root() / 'tsc-out'
+
+ typescript = custom_target(
+@@ -36,7 +36,7 @@ typescript = custom_target(
+ input: sources,
+ build_by_default: true,
+ build_always_stale: true,
+- command: [ tsc, '--outDir', tsc_out ],
++ command: [ tsc, '-p', tsc_in, '--outDir', tsc_out ],
+ output: ['tsc-output'],
+ )
+