summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-08 06:18:33 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-08 06:18:33 -0700
commit0bc6c33d0b28bcf67d84e177fc45f19b974f4087 (patch)
tree0f37c8fa944bafdd17c878b3613300ecfbce0444
downloadaur-0bc6c33d0b28bcf67d84e177fc45f19b974f4087.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c833ac417757
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = toilet
+ pkgdesc = free replacement for the FIGlet utility.
+ pkgver = 0.3
+ pkgrel = 1
+ url = http://libcaca.zoy.org/wiki/toilet
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ depends = libcaca
+ source = http://libcaca.zoy.org/files/toilet/toilet-0.3.tar.gz
+ md5sums = 9b72591cb22a30c42a3184b17cabca6f
+
+pkgname = toilet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fe08d90e253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: Christian Neukirchen <chneukirchen@gmail.com>
+# Contributor: bl4ckb1t <bl4ckb1t@gmail.com>
+pkgname=toilet
+pkgver=0.3
+pkgrel=1
+pkgdesc="free replacement for the FIGlet utility."
+arch=('i686' 'x86_64')
+url="http://libcaca.zoy.org/wiki/toilet"
+license=('custom:WTFPL')
+depends=('libcaca')
+source=(http://libcaca.zoy.org/files/toilet/$pkgname-$pkgver.tar.gz)
+md5sums=('9b72591cb22a30c42a3184b17cabca6f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/${pkgname}/COPYING
+}