summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:29:06 -0600
committergustawho2021-05-13 20:29:06 -0600
commit9e2e81ea35b04361f015a875ed9366125ad72e8e (patch)
treeee2016e1e03158458e7abbc4af7a74cf7948c321
parent0c3a69c8816964c91b4e421db6abdf1d5094c4db (diff)
downloadaur-9e2e81ea35b04361f015a875ed9366125ad72e8e.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96d91f7b78ea..9adb532b9cab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tok-git
pkgdesc = Telegram client built using Kirigami
- pkgver = r98.dce4c63
+ pkgver = r113.87f9df0
pkgrel = 1
url = https://invent.kde.org/network/tok
arch = x86_64
@@ -12,6 +12,8 @@ pkgbase = tok-git
license = GPL3
makedepends = git
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = qt5-svg
depends = kirigami2
depends = knotifications
depends = libtd-git
diff --git a/PKGBUILD b/PKGBUILD
index a56cf73ddf37..75b819d3715f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=tok-git
-pkgver=r98.dce4c63
+pkgver=r113.87f9df0
pkgrel=1
pkgdesc="Telegram client built using Kirigami"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/network/tok"
license=('GPL3')
depends=('kirigami2' 'knotifications' 'libtd-git' 'ki18n' 'icu')
-makedepends=('git' 'extra-cmake-modules')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools' 'qt5-svg')
provides=('tok')
conflicts=('tok')
source=("git+${url}.git")
@@ -23,12 +23,12 @@ pkgver() {
}
build() {
- cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
- cmake --build build --config Release
+ cmake -B build -S "${pkgname%-git}" -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo
+ cmake --build build --config RelWithDebInfo
}
package() {
- DESTDIR="${pkgdir}" cmake --install build --config Release
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
install -Dm644 "${pkgname%-git}"/app\ data/icons/48/org.kde.Tok.svg "${pkgdir}"/usr/share/icons/hicolor/scalable/apps/org.kde.Tok.svg
install -Dm644 "${pkgname%-git}"/app\ data/org.kde.Tok.desktop "${pkgdir}"/usr/share/applications/org.kde.Tok.desktop
install -Dm644 "${pkgname%-git}"/app\ data/org.kde.Tok.notifyrc "${pkgdir}"/usr/share/knotifications5/org.kde.Tok.notifyrc