summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMárton Szabó2017-12-07 19:20:07 +0100
committerMárton Szabó2017-12-07 19:20:07 +0100
commit5cb25f6d5028e43a7fb2656cb24204bbf063015e (patch)
tree35b30c11f090129339b65a51862004e2a7697f3a
downloadaur-5cb25f6d5028e43a7fb2656cb24204bbf063015e.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..777e31f70828
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tokei-git
+ pkgdesc = A blazingly fast CLOC(Count Lines Of Code) program
+ pkgver = 6.0.1
+ pkgrel = 1
+ url = https://github.com/Aaronepower/tokei
+ arch = i686
+ arch = x86_64
+ license = MIT
+ license = Apache
+ makedepends = rust
+ makedepends = cargo
+ depends = gcc-libs
+ conflicts = tokei
+ source = git+https://github.com/Aaronepower/tokei
+ sha512sums = SKIP
+
+pkgname = tokei-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..174900c6ff16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Márton Szabó <notramo@vipmail.hu>
+pkgname=tokei-git
+pkgver=6.0.1
+pkgrel=1
+pkgdesc='A blazingly fast CLOC(Count Lines Of Code) program'
+arch=('i686' 'x86_64')
+url="https://github.com/Aaronepower/tokei"
+license=('MIT' 'Apache')
+depends=('gcc-libs')
+makedepends=('rust' 'cargo')
+conflicts=('tokei')
+source=("git+https://github.com/Aaronepower/tokei")
+sha512sums=(SKIP)
+
+build() {
+ cd "${srcdir}/tokei"
+
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}/tokei"
+
+ install -Dm755 target/release/tokei "${pkgdir}/usr/bin/tokei"
+
+ install -Dm644 LICENCE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+ install -Dm644 LICENCE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+}