summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuljo2024-01-04 00:51:39 +0100
committerfuljo2024-01-04 00:51:39 +0100
commitfa95486325a3620966817d57775ce6b094763496 (patch)
treec9a4252e1a02ab0343734218a83755b886640036
downloadaur-fa95486325a3620966817d57775ce6b094763496.tar.gz
feat: first AUR release
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c8ee3bf48df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tokyonight-gtk-theme-git
+ pkgdesc = A GTK theme based on the Tokyo Night colour palette.
+ pkgver = r57.e9790345
+ pkgrel = 1
+ url = https://github.com/Fausto-Korpsvart/Tokyo-Night-GTK-Theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-themes-extra
+ optdepends = gtk-engine-murrine
+ source = git+https://github.com/Fausto-Korpsvart/Tokyo-Night-GTK-Theme.git
+ sha256sums = SKIP
+
+pkgname = tokyonight-gtk-theme-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4367ae4a50ac
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d2cf1fa5303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Alessandro Fulgini <fuljo97 at gmail dot com>
+
+pkgname='tokyonight-gtk-theme-git'
+_reponame='Tokyo-Night-GTK-Theme'
+pkgver=r57.e9790345
+pkgrel=1
+pkgdesc='A GTK theme based on the Tokyo Night colour palette.'
+arch=("any")
+url="https://github.com/Fausto-Korpsvart/${_reponame}"
+license=("GPL3")
+depends=("gnome-themes-extra")
+optdepends=("gtk-engine-murrine")
+makedepends=("git")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_reponame}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ dist="${pkgdir}/usr/share/themes"
+ mkdir -p "${dist}"
+ cd "${_reponame}"
+
+ # docs
+ install -D -m0644 -t "${pkgdir}/usr/share/doc/${pkgname}" README.md
+ install -D -m0644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+
+ cp -r themes/Tokyonight-Dark-B "${dist}/Tokyonight-Dark-B"
+ cp -r themes/Tokyonight-Dark-BL "${dist}/Tokyonight-Dark-BL"
+ cp -r themes/Tokyonight-Dark-B-LB "${dist}/Tokyonight-Dark-B-LB"
+ cp -r themes/Tokyonight-Dark-BL-LB "${dist}/Tokyonight-Dark-BL-LB"
+ cp -r themes/Tokyonight-Storm-B "${dist}/Tokyonight-Storm-B"
+ cp -r themes/Tokyonight-Storm-BL "${dist}/Tokyonight-Storm-BL"
+ cp -r themes/Tokyonight-Storm-B-LB "${dist}/Tokyonight-Storm-B-LB"
+ cp -r themes/Tokyonight-Storm-BL-LB "${dist}/Tokyonight-Storm-BL-LB"
+}