summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuba Serafinowski2012-12-02 12:01:42 +0000
committerKuba Serafinowski2012-12-02 12:04:02 +0000
commit31ab6e4977b99685028505b472994c2867c4a7f9 (patch)
treee97bc30598df1f95895a6ee2155972014c305492
parentfcc3ff0af3e470a87822d51ffa633aca3840a304 (diff)
downloadaur-31ab6e4977b99685028505b472994c2867c4a7f9.tar.gz
fix tomahawk build with newest cmake
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-build-with-new-CMake-release.patch32
-rw-r--r--PKGBUILD11
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba01482b5e2b..0f7c0a904f31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tomahawk
pkgdesc = A Music Player App written in C++/Qt
pkgver = 0.5.5
- pkgrel = 1
+ pkgrel = 2
url = http://tomahawk-player.org/
install = tomahawk.install
arch = i686
@@ -24,7 +24,9 @@ pkgbase = tomahawk
conflicts = tomahawk-git
options = !strip
source = http://download.tomahawk-player.org/tomahawk-0.5.5.tar.bz2
+ source = 0001-Fix-build-with-new-CMake-release.patch
md5sums = 708602116a849c4739480cf52a98bc1a
+ md5sums = 7798ec4e48bc40b81c5fe46ced26677f
pkgname = tomahawk
diff --git a/0001-Fix-build-with-new-CMake-release.patch b/0001-Fix-build-with-new-CMake-release.patch
new file mode 100644
index 000000000000..da43fcc9f126
--- /dev/null
+++ b/0001-Fix-build-with-new-CMake-release.patch
@@ -0,0 +1,32 @@
+From c910e1b58f01a42b9f99222e501172576d8cad06 Mon Sep 17 00:00:00 2001
+From: Dominik Schmidt <dev@dominik-schmidt.de>
+Date: Fri, 2 Nov 2012 21:43:11 +0100
+Subject: [PATCH] Fix build with new CMake release. Doesn't harm us, but really
+ looks like an upstream bug
+
+---
+ .../thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h b/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
+index 5f526e1..7b744e1 100644
+--- a/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
++++ b/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
+@@ -3,7 +3,6 @@
+
+ #include <QtCore/QObject>
+
+-#if QT_VERSION >= 0x040400 || defined(DOXYGEN_RUN)
+ #ifndef QT_NO_SHAREDMEMORY
+
+ #include <QtCore/QStringList>
+@@ -138,6 +137,5 @@ QT_END_NAMESPACE
+
+
+ #endif // QT_NO_SHAREDMEMORY
+-#endif // QT_VERSION >= 0x040400 || defined(DOXYGEN_RUN)
+
+ #endif /* __KDTOOLSCORE_KDSINGLEAPPLICATIONGUARD_H__ */
+--
+1.8.0.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 626f012d82eb..4df126952c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _buildtype="RelWithDebInfo"
pkgname=tomahawk
pkgver=0.5.5
-pkgrel=1
+pkgrel=2
pkgdesc="A Music Player App written in C++/Qt"
arch=('i686' 'x86_64')
url="http://tomahawk-player.org/"
@@ -26,8 +26,10 @@ optdepends=('tomahawk-spotify-git: spotify resolver')
provides=('tomahawk')
conflicts=('tomahawk-git')
options=(!strip)
-source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2")
-md5sums=('708602116a849c4739480cf52a98bc1a')
+source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2"
+ '0001-Fix-build-with-new-CMake-release.patch')
+md5sums=('708602116a849c4739480cf52a98bc1a'
+ '7798ec4e48bc40b81c5fe46ced26677f')
install=tomahawk.install
@@ -37,6 +39,9 @@ if [[ ${_buildtype} == "Release" ]] || [[ ${_buildtype} == "release" ]]; then
fi
build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p1 -i ${startdir}/0001-Fix-build-with-new-CMake-release.patch
+
if [[ -e ${srcdir}/${pkgname}-${pkgver}-build ]]; then rm -rf ${srcdir}/${pkgname}-${pkgver}-build; fi
mkdir ${srcdir}/${pkgname}-${pkgver}-build
cd ${srcdir}/${pkgname}-${pkgver}-build