summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2016-01-07 17:45:00 +0300
committerarcan1s2016-01-07 17:45:00 +0300
commit58f689d730593a95081140568680ad21f92ca406 (patch)
treef7cb6a1d6dd202c6929771d8c0be3134f12381a4
parentff435e542c1cc49aabd01bb370124481c1a0fd10 (diff)
downloadaur-58f689d730593a95081140568680ad21f92ca406.tar.gz
fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--libechonest-ver.patch12
3 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6c4adaec949..e9f3d0b06581 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Jan 7 14:44:49 UTC 2016
pkgbase = tomahawk
pkgdesc = A Music Player App written in C++/Qt
pkgver = 0.8.4
- pkgrel = 3
+ pkgrel = 4
url = http://tomahawk-player.org/
install = tomahawk.install
arch = i686
@@ -29,7 +31,9 @@ pkgbase = tomahawk
optdepends = jreen: Jabber support (required at build time)
optdepends = snorenotify: Notification support (required at build time)
source = http://download.tomahawk-player.org/tomahawk-0.8.4.tar.bz2
+ source = libechonest-ver.patch
sha256sums = 0fb04bc6b7009e17186b3d384057939727c6f289d22f7f9a5ed2c9c9cd800449
+ sha256sums = 424699b92eb8ea4bff654a425bddc6ecee0ba49176d088e362b545e97957fcf3
pkgname = tomahawk
diff --git a/PKGBUILD b/PKGBUILD
index b6ec0a568be9..878083c83ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=tomahawk
pkgver=0.8.4
-pkgrel=3
+pkgrel=4
pkgdesc='A Music Player App written in C++/Qt'
arch=('i686' 'x86_64')
url='http://tomahawk-player.org/'
@@ -18,13 +18,18 @@ optdepends=('kdelibs: integration with Plasma Desktop'
'jreen: Jabber support (required at build time)'
'snorenotify: Notification support (required at build time)')
-source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2")
-sha256sums=('0fb04bc6b7009e17186b3d384057939727c6f289d22f7f9a5ed2c9c9cd800449')
+source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2"
+ "libechonest-ver.patch")
+sha256sums=('0fb04bc6b7009e17186b3d384057939727c6f289d22f7f9a5ed2c9c9cd800449'
+ '424699b92eb8ea4bff654a425bddc6ecee0ba49176d088e362b545e97957fcf3')
install=tomahawk.install
prepare() {
rm -rf "build-qt4"
mkdir -p "build-qt4"
+
+ # fix libechonest version
+ patch -p0 -i "libechonest-ver.patch"
}
build() {
diff --git a/libechonest-ver.patch b/libechonest-ver.patch
new file mode 100644
index 000000000000..8df2251b917f
--- /dev/null
+++ b/libechonest-ver.patch
@@ -0,0 +1,12 @@
+diff -ruN tomahawk-0.8.4.orig/CMakeLists.txt tomahawk-0.8.4/CMakeLists.txt
+--- tomahawk-0.8.4.orig/CMakeLists.txt 2016-01-07 17:39:27.910702980 +0300
++++ tomahawk-0.8.4/CMakeLists.txt 2016-01-07 17:39:49.746567997 +0300
+@@ -263,7 +263,7 @@
+ "Used compiler neither provides std::function nor std::tr1::function")
+ endif()
+
+-macro_optional_find_package(Echonest 2.2.0)
++macro_optional_find_package(Echonest)
+ macro_log_feature(ECHONEST_FOUND "Echonest" "Qt library for communicating with The Echo Nest" "http://projects.kde.org/libechonest" TRUE "" "libechonest 2.2.0 is needed for dynamic playlists and the infosystem")
+
+ find_package(Boost REQUIRED COMPONENTS filesystem system)