summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKuba Serafinowski2013-01-12 02:13:37 +0000
committerKuba Serafinowski2013-01-12 02:13:37 +0000
commitd8c1fc7b1ce1f727fc1507e9aae1a1f7ecf99535 (patch)
tree2df38ce7ad825bd47702527e05f089ca42f509c9
parent31ab6e4977b99685028505b472994c2867c4a7f9 (diff)
downloadaur-d8c1fc7b1ce1f727fc1507e9aae1a1f7ecf99535.tar.gz
tomahawk 0.6.0beta1
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Fix-build-with-new-CMake-release.patch32
-rw-r--r--PKGBUILD16
3 files changed, 9 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f7c0a904f31..432f7da74a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tomahawk
pkgdesc = A Music Player App written in C++/Qt
- pkgver = 0.5.5
- pkgrel = 2
+ pkgver = 0.6.0beta1
+ pkgrel = 1
url = http://tomahawk-player.org/
install = tomahawk.install
arch = i686
@@ -22,11 +22,8 @@ pkgbase = tomahawk
optdepends = tomahawk-spotify-git: spotify resolver
provides = tomahawk
conflicts = tomahawk-git
- options = !strip
- source = http://download.tomahawk-player.org/tomahawk-0.5.5.tar.bz2
- source = 0001-Fix-build-with-new-CMake-release.patch
- md5sums = 708602116a849c4739480cf52a98bc1a
- md5sums = 7798ec4e48bc40b81c5fe46ced26677f
+ source = http://download.tomahawk-player.org/tomahawk-0.6.0beta1.tar.bz2
+ md5sums = 16b71a6bbe1d71684850f71b99420084
pkgname = tomahawk
diff --git a/0001-Fix-build-with-new-CMake-release.patch b/0001-Fix-build-with-new-CMake-release.patch
deleted file mode 100644
index da43fcc9f126..000000000000
--- a/0001-Fix-build-with-new-CMake-release.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From c910e1b58f01a42b9f99222e501172576d8cad06 Mon Sep 17 00:00:00 2001
-From: Dominik Schmidt <dev@dominik-schmidt.de>
-Date: Fri, 2 Nov 2012 21:43:11 +0100
-Subject: [PATCH] Fix build with new CMake release. Doesn't harm us, but really
- looks like an upstream bug
-
----
- .../thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h b/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
-index 5f526e1..7b744e1 100644
---- a/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
-+++ b/src/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
-@@ -3,7 +3,6 @@
-
- #include <QtCore/QObject>
-
--#if QT_VERSION >= 0x040400 || defined(DOXYGEN_RUN)
- #ifndef QT_NO_SHAREDMEMORY
-
- #include <QtCore/QStringList>
-@@ -138,6 +137,5 @@ QT_END_NAMESPACE
-
-
- #endif // QT_NO_SHAREDMEMORY
--#endif // QT_VERSION >= 0x040400 || defined(DOXYGEN_RUN)
-
- #endif /* __KDTOOLSCORE_KDSINGLEAPPLICATIONGUARD_H__ */
---
-1.8.0.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 4df126952c68..d302fc13b99f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@
# See http://techbase.kde.org/Development/CMake/Addons_for_KDE#Buildtypes to check what is supported.
# Default is RelWithDebInfo to help with debugging.
-_buildtype="RelWithDebInfo"
+_buildtype="Release"
##############################################################
pkgname=tomahawk
-pkgver=0.5.5
-pkgrel=2
+pkgver=0.6.0beta1
+pkgrel=1
pkgdesc="A Music Player App written in C++/Qt"
arch=('i686' 'x86_64')
url="http://tomahawk-player.org/"
@@ -25,11 +25,8 @@ makedepends=('cmake')
optdepends=('tomahawk-spotify-git: spotify resolver')
provides=('tomahawk')
conflicts=('tomahawk-git')
-options=(!strip)
-source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2"
- '0001-Fix-build-with-new-CMake-release.patch')
-md5sums=('708602116a849c4739480cf52a98bc1a'
- '7798ec4e48bc40b81c5fe46ced26677f')
+source=("http://download.tomahawk-player.org/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('16b71a6bbe1d71684850f71b99420084')
install=tomahawk.install
@@ -39,9 +36,6 @@ if [[ ${_buildtype} == "Release" ]] || [[ ${_buildtype} == "release" ]]; then
fi
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i ${startdir}/0001-Fix-build-with-new-CMake-release.patch
-
if [[ -e ${srcdir}/${pkgname}-${pkgver}-build ]]; then rm -rf ${srcdir}/${pkgname}-${pkgver}-build; fi
mkdir ${srcdir}/${pkgname}-${pkgver}-build
cd ${srcdir}/${pkgname}-${pkgver}-build