summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElio E. Duarte2015-12-08 21:25:42 -0200
committerElio E. Duarte2015-12-08 21:25:42 -0200
commit635ed8fbd2fd59a83ebf5397b62e91fa1ad951b0 (patch)
tree5dba744fedf0e9b9c44c9ad3db573a552710f035
downloadaur-635ed8fbd2fd59a83ebf5397b62e91fa1ad951b0.tar.gz
Initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a37a19269bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 23:19:09 UTC 2015
+pkgbase = tomate-alarm-plugin
+ pkgdesc = Tomate plugin that shows screen notifications
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/eliostvs/tomate-notify-plugin
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = gtk3
+ depends = python
+ depends = gstreamer
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = tomate-gtk
+ options = !emptydirs
+ source = https://github.com/eliostvs/tomate-alarm-plugin/archive/0.3.0.tar.gz
+ md5sums = 19026e8ad56ef54b5cacd66c46747e14
+
+pkgname = tomate-alarm-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8476da5adb48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
+pkgname=tomate-alarm-plugin
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Tomate plugin that shows screen notifications"
+arch=('any')
+url="https://github.com/eliostvs/tomate-notify-plugin"
+license=('GPL')
+depends=('gtk3'
+ 'python'
+ 'gstreamer'
+ 'gst-plugins-base'
+ 'gst-plugins-good'
+ 'tomate-gtk')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/eliostvs/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('19026e8ad56ef54b5cacd66c46747e14')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file