summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElio Esteves Duarte2021-05-07 20:23:05 -0300
committerElio Esteves Duarte2021-05-07 20:23:05 -0300
commit1158c24105708e1b7d273552c86b9bdbf91cbf26 (patch)
treedceefb6f78581e9923bf6c996b003d8ad63ca25a
downloadaur-1158c24105708e1b7d273552c86b9bdbf91cbf26.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3de6aa61cfde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tomate-breakscreen-plugin
+ pkgdesc = Tomate plugin that shows a full screen window which prevents users from using the computer during a break
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/eliostvs/tomate-breakscreen-plugin
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = tomate-gtk
+ options = !emptydirs
+ source = https://github.com/eliostvs/tomate-breakscreen-plugin/archive/0.2.0.tar.gz
+ md5sums = 067df380422e8aa2c284c7a37bb2f3d6
+
+pkgname = tomate-breakscreen-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be975f98fa9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
+pkgname=tomate-breakscreen-plugin
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Tomate plugin that shows a full screen window which prevents users from using the computer during a break"
+arch=('any')
+url="https://github.com/eliostvs/tomate-breakscreen-plugin"
+license=('GPL')
+depends=('python'
+ 'tomate-gtk')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/eliostvs/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('067df380422e8aa2c284c7a37bb2f3d6')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: