summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElio E. Duarte2015-12-08 20:43:24 -0200
committerElio E. Duarte2015-12-08 20:43:24 -0200
commitef4bcf3030508ac24d4f6b642b1002e61c08e484 (patch)
treeb34f2c089321ed0b2403e9dc7046e057ee5d6602
downloadaur-ef4bcf3030508ac24d4f6b642b1002e61c08e484.tar.gz
Initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD27
-rw-r--r--tomate-notify-plugin.install11
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d423cb66e900
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 22:42:47 UTC 2015
+pkgbase = tomate-notify-plugin
+ pkgdesc = Tomate plugin that shows screen notifications
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/eliostvs/tomate-notify-plugin
+ install = tomate-notify-plugin.install
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = gtk-update-icon-cache
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libnotify
+ depends = python
+ depends = tomate-gtk
+ options = !emptydirs
+ source = https://github.com/eliostvs/tomate-notify-plugin/archive/0.3.0.tar.gz
+ md5sums = 19026e8ad56ef54b5cacd66c46747e14
+
+pkgname = tomate-notify-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d41d29ac565
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Elio Esteves Duarte <elio.esteves.duarte@gmail.com>
+pkgname=tomate-notify-plugin
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Tomate plugin that shows screen notifications"
+arch=('any')
+url="https://github.com/eliostvs/tomate-notify-plugin"
+license=('GPL')
+depends=( 'gtk-update-icon-cache'
+ 'gtk3'
+ 'hicolor-icon-theme'
+ 'libnotify'
+ 'python'
+ 'tomate-gtk')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/eliostvs/tomate-notify-plugin/archive/$pkgver.tar.gz")
+md5sums=('19026e8ad56ef54b5cacd66c46747e14')
+install=tomate-notify-plugin.install
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file
diff --git a/tomate-notify-plugin.install b/tomate-notify-plugin.install
new file mode 100644
index 000000000000..f46ccdc5ee50
--- /dev/null
+++ b/tomate-notify-plugin.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file