summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraji2019-01-26 15:53:38 +0100
committeraji2019-01-26 15:53:38 +0100
commit84c87bba9df8f49fe7f15819f1f8504b5d9f7f05 (patch)
tree48e22ce0b30a798b1a68004a2e84a96fb6bf933d
downloadaur-84c87bba9df8f49fe7f15819f1f8504b5d9f7f05.tar.gz
First AUR package for tomato (v0.2.0)
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf364e4c4cc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tomato
+ pkgdesc = AUR local repository manager
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/aji-prod/tomato
+ arch = any
+ license = GPL3
+ depends = docker
+ source = tomato-0.2.0.tar.gz::https://github.com/aji-prod/tomato/archive/v0.2.0.tar.gz
+ md5sums = 370bbd91976eecb94d7cc8fbf6b2404e
+
+pkgname = tomato
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cab3c29add2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer : aji <43468383+aji-prod@users.noreply.github.com>
+pkgname=tomato
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="AUR local repository manager"
+arch=('any')
+url="https://github.com/aji-prod/tomato"
+license=('GPL3')
+source=(
+ "${pkgname}-${pkgver}.tar.gz"::https://github.com/aji-prod/tomato/archive/v"${pkgver}".tar.gz
+)
+
+md5sums=('370bbd91976eecb94d7cc8fbf6b2404e')
+
+depends=(
+ 'docker'
+)
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 tomato "$pkgdir/usr/bin/tomato"
+ install -Dm644 tomato.conf "$pkgdir/etc/tomato.conf"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licences/$pkgname/LICENSE"
+ for dockfile in $(cd ./docker && ls -A ./*); do
+ install -Dm644 docker/$dockfile "$pkgdir/usr/share/$pkgname/$dockfile"
+ done
+ for hookfile in $(cd ./pacman && ls ./*); do
+ install -Dm644 pacman/$hookfile "$pkgdir/usr/share/libalpm/hooks/$hookfile"
+ done
+ for sysfile in $(cd ./systemd && ls ./*.{timer,service}); do
+ install -Dm644 systemd/$sysfile "$pkgdir/usr/lib/systemd/system/$sysfile"
+ done
+ install -Dm644 "systemd/tomato-update.conf" "$pkgdir/usr/share/tomato/tomato-update.conf"
+ install -Dm644 "complete/tomato.bash" "$pkgdir/usr/share/bash-completion/completions/tomato"
+ mkdir -p -m755 "$pkgdir/var/pkg/tomato"
+}