summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-02-21 11:09:25 +0100
committerMichael Straube2017-02-21 11:09:25 +0100
commit9009389117359c269f255823c2b8d6f67f15cb5a (patch)
treec7bbdb90948a795a03c75f867f720860bb79c002
parentb9b761242d0fa40aa19b361e234e163dcb71aa29 (diff)
downloadaur-9009389117359c269f255823c2b8d6f67f15cb5a.tar.gz
Use gendesk
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD14
-rw-r--r--tomatoes.desktop9
3 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68df4a60249b..afac9bfff1bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = tomatoes
arch = i686
arch = x86_64
license = ZLIB
+ makedepends = gendesk
depends = sdl_image
depends = sdl_mixer
depends = glu
@@ -14,13 +15,11 @@ pkgbase = tomatoes
source = 0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch
source = 0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch
source = 0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch
- source = tomatoes.desktop
sha256sums = 126d001532ee5b81cc95e1a86a274d11669b8c8f65c8235ae2e9b8fbdfab4a60
sha256sums = 69a3af1994cb58409be9b469e1aa4bdb91c405d99071c7431526640ec53d1300
sha256sums = 49b2944b268efcfc660da682dfbc2404558e52ba034cc39d310e8c74ed89646c
sha256sums = 4f9e72fcb3d4427ec633d9ce6f3bb73179cfac1dba55f1ff7f68725f63f1d55d
sha256sums = 0dcab19428d4904d1d5ab0099b23f6d9f3f53399303166ad3cea6e743efcd9bf
- sha256sums = 15588e33cd9cd532857bb54310d6cd31a75a3f1f0de5b524a0b701c6a317fec7
pkgname = tomatoes
diff --git a/PKGBUILD b/PKGBUILD
index cfada2b1daa3..1dfe3d415665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,17 @@ url="http://tomatoes.sourceforge.net"
license=('ZLIB')
arch=('i686' 'x86_64')
depends=('sdl_image' 'sdl_mixer' 'glu')
+makedepends=('gendesk')
source=("https://downloads.sourceforge.net/$pkgname/$pkgname-linux-src-$pkgver.tar.bz2"
"https://downloads.sourceforge.net/$pkgname/$pkgname-linux-1.5.tar.bz2"
"0001-tomatoes-1.55-makefile-Append-to-compile-flags.patch"
"0002-tomatoes-1.55-Quell-const-char-conversion-warnings.patch"
- "0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch"
- "tomatoes.desktop")
+ "0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch")
sha256sums=('126d001532ee5b81cc95e1a86a274d11669b8c8f65c8235ae2e9b8fbdfab4a60'
'69a3af1994cb58409be9b469e1aa4bdb91c405d99071c7431526640ec53d1300'
'49b2944b268efcfc660da682dfbc2404558e52ba034cc39d310e8c74ed89646c'
'4f9e72fcb3d4427ec633d9ce6f3bb73179cfac1dba55f1ff7f68725f63f1d55d'
- '0dcab19428d4904d1d5ab0099b23f6d9f3f53399303166ad3cea6e743efcd9bf'
- '15588e33cd9cd532857bb54310d6cd31a75a3f1f0de5b524a0b701c6a317fec7')
+ '0dcab19428d4904d1d5ab0099b23f6d9f3f53399303166ad3cea6e743efcd9bf')
prepare() {
cd $pkgname-$pkgver
@@ -30,6 +29,9 @@ prepare() {
patch -p0 < ../0003-tomatoes-1.55-config-hiscore-file-saving-loading.patch
sed -n '7,27p' README-src > LICENSE
+
+ gendesk -f -n --pkgname=$pkgname --comment="I Have No Tomatoes" \
+ --categories="Application;Game;ArcadeGame;"
}
build() {
@@ -51,9 +53,7 @@ package() {
cp -r ../$pkgname-1.5/* "$pkgdir"/usr/share/$pkgname
install -Dm755 tomatoes "$pkgdir"/usr/bin/tomatoes
-
install -Dm644 icon.png "$pkgdir"/usr/share/pixmaps/tomatoes.png
- install -Dm644 ../tomatoes.desktop "$pkgdir"/usr/share/applications/tomatoes.desktop
-
+ install -Dm644 tomatoes.desktop "$pkgdir"/usr/share/applications/tomatoes.desktop
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/tomatoes.desktop b/tomatoes.desktop
deleted file mode 100644
index 857859a3422c..000000000000
--- a/tomatoes.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Version=1.0
-Name=Tomatoes
-Type=Application
-Comment=I Have No Tomatoes
-Exec=/usr/bin/tomatoes
-Icon=tomatoes
-Categories=Application;Game;ArcadeGame;