summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-08-03 01:21:21 +0200
committerNarrat2015-08-03 01:21:21 +0200
commit5ef58a10b38024058fc14ecb32a88ede2318b755 (patch)
tree23ce68d526bae8a33fe303dc1c14d70f8279135e
parentec22a87f3fb97d296d3b1c7c04d085848ddc5863 (diff)
downloadaur-5ef58a10b38024058fc14ecb32a88ede2318b755.tar.gz
tomb: Small adjustment to zsh-completion file
Now files can be completed again. Remaining issues: * All options can only be completed at first position And adjusted gitignore
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD6
-rw-r--r--_tomb25
4 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84d01f22b59..401915fe1376 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tomb-git
pkgdesc = simple tool to manage encrypted storage
- pkgver = 2.0.1.r5.gd8c5cd2
- pkgrel = 1
+ pkgver = 2.1.r1.ge79aaa9
+ pkgrel = 2
url = http://tomb.dyne.org/
install = tomb-git.install
arch = any
@@ -13,7 +13,7 @@ pkgbase = tomb-git
source = tomb::git://github.com/dyne/Tomb.git
source = _tomb
sha256sums = SKIP
- sha256sums = ff16b05d02a18e512e9ede98542208c0605b693d997a4248bf6c1fe06f7adbd6
+ sha256sums = 3952cda7762fded6e9fd03be4b4b2634f50ea20fba72c6a2803978f228630749
pkgname = tomb-git
depends = bc
diff --git a/.gitignore b/.gitignore
index 39c4da584ff3..b0cd9c50a2fa 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
-*/src
-*/pkg
+src/
+pkg/
*.gz
*.xz
*.bz2
@@ -10,6 +10,6 @@
*.txt
*.log
*.scm
-*/tomb
-*/*.pkg
-*/*.asc
+tomb/
+*.pkg
+*.asc
diff --git a/PKGBUILD b/PKGBUILD
index 1d88792e6432..e38254b17b0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_name=tomb
pkgbase="${_name}-git"
pkgname=("${_name}-git" "${_name}-kdf-git")
-pkgver=2.0.1.r5.gd8c5cd2
-pkgrel=1
+pkgver=2.1.r1.ge79aaa9
+pkgrel=2
pkgdesc="simple tool to manage encrypted storage"
arch=('any')
url="http://tomb.dyne.org/"
@@ -20,7 +20,7 @@ provides=("${_name}")
source=("${_name}::git://github.com/dyne/${_name//t/T}.git"
"_${_name}")
sha256sums=('SKIP'
- 'ff16b05d02a18e512e9ede98542208c0605b693d997a4248bf6c1fe06f7adbd6')
+ '3952cda7762fded6e9fd03be4b4b2634f50ea20fba72c6a2803978f228630749')
pkgver() {
diff --git a/_tomb b/_tomb
index d3a43c43d9f4..42384ddfde47 100644
--- a/_tomb
+++ b/_tomb
@@ -1,28 +1,31 @@
#compdef tomb
+
+#typeset -A opt_args
+
_tomb_commands(){
local -a _cmds
_cmds=(
+ 'bury:hide tomb key in a jpeg'
+ 'close:close specified tomb or all open tombs'
'dig:create a new empty TOMB file of size -s in MB'
+ 'engrave:makes a QR code of a KEY to be saved on paper'
+ 'exhume:extract a buried tomb key'
'forge:create a new KEY file and set its password'
- 'lock:installs a lock on a TOMB to use it with KEY'
- 'open:open an existing tomb'
'index:update the search indexes of tombs'
- 'search:looks for filenames matching text patterns'
'list:list specified tomb or all open tombs'
- 'close:close specified tomb or all open tombs'
- 'slam:close specified tomb and kill all PIDs using it'
- 'resize:resize specified tomb (only increase)'
+ 'lock:installs a lock on a TOMB to use it with KEY'
+ 'open:open an existing tomb'
'passwd:change password of a key'
+ 'resize:resize specified tomb (only increase)'
+ 'search:looks for filenames matching text patterns'
'setkey:change the KEY locking a TOMB (needs old one)'
- 'engrave:makes a QR code of a KEY to be saved on paper'
- 'bury:hide tomb key in a jpeg'
- 'exhume:extract a buried tomb key'
+ 'slam:close specified tomb and kill all PIDs using it'
)
_describe 'command' _cmds
}
_arguments -C -A "-*" \
- '1:command:_tomb_commands' \
+ "1:command:_tomb_commands" \
-h'[show help]' \
-s'[size of tomb (MB)]' \
-k'[path to the key to be used (-k - to read from stdin)]' \
@@ -34,3 +37,5 @@ _arguments -C -A "-*" \
-D'[print debugging information]' \
--kdf'[specify the KDF method]' \
--no-color'[do not use colors]' \
+ '*: :_files' && ret=0
+