summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:57:44 +0200
committerNarrat2015-05-13 22:57:44 +0200
commitec22a87f3fb97d296d3b1c7c04d085848ddc5863 (patch)
treef0746e67d12263636b0bc0a9f01e8a73e59f5204
downloadaur-ec22a87f3fb97d296d3b1c7c04d085848ddc5863.tar.gz
tomb: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO38
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD62
-rw-r--r--_tomb36
-rw-r--r--tomb-git.install12
5 files changed, 163 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d84d01f22b59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = tomb-git
+ pkgdesc = simple tool to manage encrypted storage
+ pkgver = 2.0.1.r5.gd8c5cd2
+ pkgrel = 1
+ url = http://tomb.dyne.org/
+ install = tomb-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = libgcrypt
+ provides = tomb
+ conflicts = tomb
+ source = tomb::git://github.com/dyne/Tomb.git
+ source = _tomb
+ sha256sums = SKIP
+ sha256sums = ff16b05d02a18e512e9ede98542208c0605b693d997a4248bf6c1fe06f7adbd6
+
+pkgname = tomb-git
+ depends = bc
+ depends = cryptsetup
+ depends = gnupg
+ depends = sudo
+ depends = zsh
+ depends = e2fsprogs
+ optdepends = steghide: steganography
+ optdepends = dcfldd: show nice progress during massive I/O
+ optdepends = wipe: secure file deletion
+ optdepends = qrencode: for paper backups of keys
+ optdepends = swish-e: file content indexer
+
+pkgname = tomb-kdf-git
+ pkgdesc = Crypto Undertaker extensions to improve password security
+ arch = i686
+ arch = x86_64
+ depends = libgcrypt
+ provides = tomb-kdf
+ conflicts = tomb-kdf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..39c4da584ff3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/tomb
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d88792e6432
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Lex Black <autumn-wind at web dot de>
+# Contributor: Rich Li <rich at dranek com>
+# Contributor: Sam Stuewe <halosghost at archlinux dot org>
+# Contributor: David Lo Re <boyska@gmail.com>
+# Contributor: nignux <nignux@freaknet.org>
+
+_name=tomb
+pkgbase="${_name}-git"
+pkgname=("${_name}-git" "${_name}-kdf-git")
+pkgver=2.0.1.r5.gd8c5cd2
+pkgrel=1
+pkgdesc="simple tool to manage encrypted storage"
+arch=('any')
+url="http://tomb.dyne.org/"
+license=('GPL3')
+makedepends=('git' 'libgcrypt')
+install="${pkgname}.install"
+conflicts=("${_name}")
+provides=("${_name}")
+source=("${_name}::git://github.com/dyne/${_name//t/T}.git"
+ "_${_name}")
+sha256sums=('SKIP'
+ 'ff16b05d02a18e512e9ede98542208c0605b693d997a4248bf6c1fe06f7adbd6')
+
+
+pkgver() {
+ cd "${_name}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+}
+
+build() {
+ cd "${_name}/extras/kdf-keys"
+ make
+}
+
+package_tomb-git() {
+ depends=('bc' 'cryptsetup' 'gnupg' 'sudo' 'zsh' 'e2fsprogs')
+ optdepends=('steghide: steganography'
+ 'dcfldd: show nice progress during massive I/O'
+ 'wipe: secure file deletion'
+ 'qrencode: for paper backups of keys'
+ 'swish-e: file content indexer')
+
+ cd "${_name}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+
+ cd "extras/po"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+
+ install -Dm644 "${srcdir}/_${_name}" "${pkgdir}/usr/share/zsh/site-functions/_${_name}"
+}
+
+package_tomb-kdf-git() {
+ pkgdesc="Crypto Undertaker extensions to improve password security"
+ arch=('i686' 'x86_64')
+ depends=('libgcrypt')
+ conflicts=("${_name}-kdf")
+ provides=("${_name}-kdf")
+
+ cd "${_name}/extras/kdf-keys"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}
diff --git a/_tomb b/_tomb
new file mode 100644
index 000000000000..d3a43c43d9f4
--- /dev/null
+++ b/_tomb
@@ -0,0 +1,36 @@
+#compdef tomb
+_tomb_commands(){
+ local -a _cmds
+ _cmds=(
+ 'dig:create a new empty TOMB file of size -s in MB'
+ 'forge:create a new KEY file and set its password'
+ 'lock:installs a lock on a TOMB to use it with KEY'
+ 'open:open an existing tomb'
+ 'index:update the search indexes of tombs'
+ 'search:looks for filenames matching text patterns'
+ 'list:list specified tomb or all open tombs'
+ 'close:close specified tomb or all open tombs'
+ 'slam:close specified tomb and kill all PIDs using it'
+ 'resize:resize specified tomb (only increase)'
+ 'passwd:change password of a key'
+ 'setkey:change the KEY locking a TOMB (needs old one)'
+ 'engrave:makes a QR code of a KEY to be saved on paper'
+ 'bury:hide tomb key in a jpeg'
+ 'exhume:extract a buried tomb key'
+ )
+ _describe 'command' _cmds
+}
+
+_arguments -C -A "-*" \
+ '1:command:_tomb_commands' \
+ -h'[show help]' \
+ -s'[size of tomb (MB)]' \
+ -k'[path to the key to be used (-k - to read from stdin)]' \
+ -n'[do not process hooks found in tomb]' \
+ -o'[mount options used to open]' \
+ -f'[force operation]' \
+ -v'[print version information]' \
+ -q'[run quietly]' \
+ -D'[print debugging information]' \
+ --kdf'[specify the KDF method]' \
+ --no-color'[do not use colors]' \
diff --git a/tomb-git.install b/tomb-git.install
new file mode 100644
index 000000000000..f4a0690b4e52
--- /dev/null
+++ b/tomb-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ update-mime-database usr/share/mime
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}