summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyndair2022-10-23 22:38:40 +0100
committerkyndair2022-10-23 22:38:40 +0100
commit23f7664ad2c325fea8963b384990daae964fcdc4 (patch)
tree67d0009db24f6fa8ee0a20b4d183ce5827192615
downloadaur-23f7664ad2c325fea8963b384990daae964fcdc4.tar.gz
initial setup
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcf111580d02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tome4-embers_of_rage
+ pkgdesc = Embers of Rage DLC for tome4.
+ pkgver = 1.7.4
+ pkgrel = 1
+ url = http://tome.te4.org/
+ arch = any
+ license = custom
+ depends = tome4
+ noextract = orcs.teaac
+ source = orcs.teaac::te4://orcs.teaac
+ sha256sums = f9e5cd38221bd6484ee331d6615b4db3db0597db8796fba0346caa68247f4117
+
+pkgname = tome4-embers_of_rage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1141ff44ae6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+# This requires the user to login into their tome account and download the DLC into the same folder as the PKGBUILD.
+
+pkgname=tome4-embers_of_rage
+_pkgname=orcs
+pkgver='1.7.4'
+pkgrel='1'
+pkgdesc="Embers of Rage DLC for tome4."
+arch=('any')
+url="http://tome.te4.org/"
+license=('custom')
+depends=('tome4')
+source=("orcs.teaac::te4://orcs.teaac")
+# don't download anything automatically
+DLAGENTS+=("te4::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+sha256sums=('f9e5cd38221bd6484ee331d6615b4db3db0597db8796fba0346caa68247f4117')
+noextract=(orcs.teaac)
+
+package() {
+
+ install -Dm644 "${srcdir}/${_pkgname}.teaac" "${pkgdir}/opt/tome4/game/addons/${_pkgname}.teaac"
+
+}