summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-05-17 04:51:13 +0200
committerFrederik Schwan2020-05-17 04:51:13 +0200
commit76c46ab85253e2ae42bbda5355faf5ed6f4419be (patch)
treef7f3c71000073879676abf8f0f4ba387021d7d03
parent34a48bc55d6e5d57aca5caa872d5ba085276287e (diff)
downloadaur-76c46ab85253e2ae42bbda5355faf5ed6f4419be.tar.gz
review by anthraxx
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4a5a43d49e6..cb76c9e332dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = tomighty
makedepends = git
depends = bash
depends = java-runtime
- source = git+https://github.com/tomighty/tomighty.git#branch=version-0.7
+ source = git+https://github.com/tomighty/tomighty.git#commit=e4064d110b11ddd5a7fb8d457f635813da212af2
source = pomxml.patch
source = tomighty.sh
source = tomighty.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 08fd2d8ca88b..b40d131f60ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url='https://tomighty.github.io/'
license=('Apache')
depends=('bash' 'java-runtime')
makedepends=('imagemagick' 'maven' 'git')
-source=("git+https://github.com/tomighty/tomighty.git#branch=version-0.7"
+source=("git+https://github.com/tomighty/tomighty.git#commit=e4064d110b11ddd5a7fb8d457f635813da212af2"
pomxml.patch
tomighty.sh
tomighty.desktop
@@ -29,12 +29,11 @@ prepare() {
build() {
cd ${pkgname}
mvn clean package
+ convert ${srcdir}/tomato.ico ${srcdir}/tomato.png
}
package() {
- convert tomato.ico tomato.png
install -Dm 644 tomato-0.png "${pkgdir}"/usr/share/pixmaps/${pkgname}.png
-
install -Dm 644 ${pkgname}/target/${pkgname}-${pkgver}.jar "${pkgdir}"/usr/share/java/${pkgname}/${pkgname}.jar
install -Dm 644 ${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
install -Dm 755 ${pkgname}.sh "${pkgdir}/"usr/bin/${pkgname}