summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlavi Pantaleev2015-07-29 02:59:18 +0300
committerSlavi Pantaleev2015-07-29 02:59:18 +0300
commit811665d128f9166bf898115c0fdbda6970f5efe9 (patch)
treecdeb379443b5b1345564b19382c87934a16c3b67
downloadaur-811665d128f9166bf898115c0fdbda6970f5efe9.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD31
-rw-r--r--tomighty2
-rw-r--r--tomighty.desktop9
5 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a303f0f5798f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tomighty
+ pkgdesc = Desktop timer for Pomodoro Technique users
+ pkgver = 0.7.1
+ pkgrel = 3
+ url = http://www.tomighty.org/
+ arch = any
+ license = Apache
+ makedepends = imagemagick
+ depends = java-runtime
+ source = tomighty
+ source = tomighty.desktop
+ source = http://tomighty.googlecode.com/files/tomighty-0.7.1.jar
+ source = https://github.com/ccidral/tomighty/raw/50d0094c024f1923bd0d6ff1bf77572ae5f5b5f6/img/tomato.ico
+ md5sums = 941bdeb609169335cea3e9cf40904883
+ md5sums = 66425a9e185788f720b466ca1caf5769
+ md5sums = 73094fd45e3683dc0b560642e0543176
+ md5sums = f92eb060209cc142b9d6ff644f751b5f
+
+pkgname = tomighty
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dda300461871
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.xz
+*.gz
+pkg
+src
+vcs-repository
+tomato.ico
+tomighty-*.jar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e42b7d196a15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Slavi Pantaleev <s.pantaleev at gmail.com>
+
+pkgname=tomighty
+pkgver=0.7.1
+pkgrel=3
+pkgdesc='Desktop timer for Pomodoro Technique users'
+arch=('any')
+url="http://www.tomighty.org/"
+license=('Apache')
+depends=('java-runtime')
+makedepends=('imagemagick')
+source=('tomighty'
+ 'tomighty.desktop'
+ 'http://tomighty.googlecode.com/files/'$pkgname'-'$pkgver'.jar'
+ 'https://github.com/ccidral/tomighty/raw/50d0094c024f1923bd0d6ff1bf77572ae5f5b5f6/img/tomato.ico')
+md5sums=('941bdeb609169335cea3e9cf40904883'
+ '66425a9e185788f720b466ca1caf5769'
+ '73094fd45e3683dc0b560642e0543176'
+ 'f92eb060209cc142b9d6ff644f751b5f')
+
+package() {
+ # This extracts several different sizes as {tomato}-{number}.png
+ # tomato-0.png is the largest and the one we want
+ convert $srcdir/tomato.ico $srcdir/tomato.png
+ install -Dm 644 $srcdir/tomato-0.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ install -Dm 644 $srcdir/$pkgname-$pkgver.jar $pkgdir/usr/share/java/$pkgname/$pkgname.jar
+ install -Dm 644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ install -Dm 755 $pkgname $pkgdir/usr/bin/$pkgname
+}
diff --git a/tomighty b/tomighty
new file mode 100644
index 000000000000..740ecf33ce3f
--- /dev/null
+++ b/tomighty
@@ -0,0 +1,2 @@
+#!/bin/sh
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/tomighty/tomighty.jar'
diff --git a/tomighty.desktop b/tomighty.desktop
new file mode 100644
index 000000000000..4b92c6db3dd6
--- /dev/null
+++ b/tomighty.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Tomighty
+Comment=Desktop timer for Pomodoro Technique users
+Exec=tomighty
+Icon=tomighty
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=GTK;Office;Java;TrayIcon;