summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordysphoria2019-05-16 00:15:39 +0100
committerdysphoria2019-05-16 00:15:39 +0100
commite19233bd7716db6b09bf4b1c465337b530a9340b (patch)
tree12d8c94d752c127c076a8f8e06c67e29414cc043
parent05c4438db8da9240c23bd96c52bc8a916d4e330e (diff)
downloadaur-e19233bd7716db6b09bf4b1c465337b530a9340b.tar.gz
[pkg] update versions and depends
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--tomoyo-auditd.service2
-rw-r--r--tomoyo-tools.install30
4 files changed, 50 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8a7364a1f3b..e3bc8701e047 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,24 @@
-# Generated by mksrcinfo v8
-# Mon May 6 03:47:26 UTC 2019
pkgbase = tomoyo-tools-25
- pkgdesc = TOMOYO Linux userspace tools for Linux kernels >=3.2 and <5.1
+ pkgdesc = TOMOYO Linux 2.5.x userspace tools for Linux kernel 3.5 to 5.1
pkgver = 2.5.0.20170102
- pkgrel = 1
+ pkgrel = 2
url = https://tomoyo.osdn.jp
install = tomoyo-tools.install
arch = x86_64
license = GPL
depends = ncurses>=6.0
- conflicts = linux>=5.1
- conflicts = linux-zen>=5.1
- conflicts = linux-hardened>=5.1
+ optdepends = linux-lts-tomoyo: TOMOYO Linux enabled kernel
conflicts = tomoyo-tools
replaces = tomoyo-tools<2.6
source = https://jaist.dl.osdn.jp/tomoyo/53357/tomoyo-tools-2.5.0-20170102.tar.gz
source = https://jaist.dl.osdn.jp/tomoyo/53357/tomoyo-tools-2.5.0-20170102.tar.gz.asc
source = tomoyo-tools.install
source = tomoyo-auditd.service
+ validpgpkeys = 43C83369623D7AD3A96C2FC7425F128D0C64F52A
sha256sums = 00fedfac5e514321250bbe69eaccc732c8a8158596f77a785c2e3ae9f9968283
sha256sums = SKIP
- sha256sums = 0df2401456f5377df529c1c8774670636b3ba365534d7ecbaf96b2e7ef6bf093
- sha256sums = 7c3c01a8ba34af9dc3601d470afdd0d3a2b01a1ca1951e3479cfd1fb4dfdafa3
+ sha256sums = 733cec41707f27abaf2da3bfc66a40fa02c5da539dd0352a1f497e5fabd6311c
+ sha256sums = faf16938762902a73e50fdaa82d17c0fe13ef3c305508b55fa2cc64bacf998dd
pkgname = tomoyo-tools-25
diff --git a/PKGBUILD b/PKGBUILD
index f93750d31648..7179376e1041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,44 +9,50 @@ _file=53357
_basever=2.5.0
_timestamp=20170102
pkgver=${_basever}.${_timestamp}
-pkgrel=1
-pkgdesc='TOMOYO Linux userspace tools for Linux kernels >=3.2 and <5.1'
+pkgrel=2
+pkgdesc='TOMOYO Linux 2.5.x userspace tools for Linux kernel 3.5 to 5.1'
arch=('x86_64')
url='https://tomoyo.osdn.jp'
#url='http://sourceforge.jp/projects/tomoyo/releases/?package_id=9818'
license=('GPL')
depends=('ncurses>=6.0')
-conflicts=('linux>=5.1' 'linux-zen>=5.1' 'linux-hardened>=5.1' 'tomoyo-tools')
+optdepends=('linux-lts-tomoyo: TOMOYO Linux enabled kernel')
+conflicts=('tomoyo-tools')
replaces=('tomoyo-tools<2.6')
install=tomoyo-tools.install
-source=("https://jaist.dl.osdn.jp/tomoyo/${_file}/${_pkgname}-${_basever}-${_timestamp}.tar.gz"{,.asc}
+source=(
+ "https://jaist.dl.osdn.jp/tomoyo/${_file}/${_pkgname}-${_basever}-${_timestamp}.tar.gz"{,.asc}
'tomoyo-tools.install'
- 'tomoyo-auditd.service')
+ 'tomoyo-auditd.service'
+ )
sha256sums=('00fedfac5e514321250bbe69eaccc732c8a8158596f77a785c2e3ae9f9968283'
'SKIP'
- '0df2401456f5377df529c1c8774670636b3ba365534d7ecbaf96b2e7ef6bf093'
- '7c3c01a8ba34af9dc3601d470afdd0d3a2b01a1ca1951e3479cfd1fb4dfdafa3')
-validpgpkeys=('43C83369623D7AD3A96C2FC7425F128D0C64F52A')
+ '733cec41707f27abaf2da3bfc66a40fa02c5da539dd0352a1f497e5fabd6311c'
+ 'faf16938762902a73e50fdaa82d17c0fe13ef3c305508b55fa2cc64bacf998dd')
+validpgpkeys=(
+ '43C83369623D7AD3A96C2FC7425F128D0C64F52A' # Tetsuo Handa
+ )
prepare() {
- cd "${srcdir}/${_pkgname}"
- sed -i \
- -e 's|usr/sbin|usr/bin|g' \
- -e 's|sbin|usr/bin|g' \
- usr_lib_tomoyo/init_policy.c
+ cd "${srcdir}/${_pkgname}"
+ sed -i \
+ -e 's|usr/sbin|usr/bin|g' \
+ -e 's|sbin|usr/bin|g' \
+ usr_lib_tomoyo/init_policy.c
}
build() {
- cd "${srcdir}/${_pkgname}"
- make USRSBINDIR=/usr/bin SBINDIR=/usr/bin
+ cd "${srcdir}/${_pkgname}"
+ make USRSBINDIR=/usr/bin SBINDIR=/usr/bin
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
- _unitdir="$(pkg-config --variable=systemdsystemunitdir systemd)"
+ _unitdir="$(pkg-config --variable=systemdsystemunitdir systemd)"
- make USRSBINDIR=/usr/bin SBINDIR=/usr/bin INSTALLDIR="${pkgdir}" install
- install -Dm644 "${srcdir}/tomoyo-auditd.service" \
- "${pkgdir}/${_unitdir}/tomoyo-auditd.service"
+ make USRSBINDIR=/usr/bin SBINDIR=/usr/bin INSTALLDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}/tomoyo-auditd.service" \
+ "${pkgdir}/${_unitdir}/tomoyo-auditd.service"
}
+
diff --git a/tomoyo-auditd.service b/tomoyo-auditd.service
index a9cce01df710..75cc83ab0bc8 100644
--- a/tomoyo-auditd.service
+++ b/tomoyo-auditd.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Tomoyo Auditing
+Description=TOMOYO Linux Auditing Daemon
[Service]
Type=forking
diff --git a/tomoyo-tools.install b/tomoyo-tools.install
index e5777b46efc6..156b99c24de0 100644
--- a/tomoyo-tools.install
+++ b/tomoyo-tools.install
@@ -1,18 +1,22 @@
post_install () {
- echo " * To enable TOMOYO Linux, append 'security=tomoyo' to the kernel"
- echo ' boot options and initialize policy with this command:'
- echo ' /usr/lib/tomoyo/init_policy'
- echo ' Also you may pass TOMOYO_trigger parameter'
- echo ' if CONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER'
- echo ' kernel option has wrong value'
- echo ''
- echo ' * Kernel version >=3.2 and <5.1 is required'
- echo " Your version is $(uname -r)"
- echo ' !! Using the wrong version may render your system unbootable'
+ echo " * To initialize TOMOYO Linux configuration, run"
+ echo ' /usr/lib/tomoyo/init_policy'
+ echo " To enable TOMOYO Linux append 'security=tomoyo'"
+ echo ' to the kernel boot options'
+ echo ' Also you may pass TOMOYO_trigger kernel boot option'
+ echo ' if CONFIG_SECURITY_TOMOYO_ACTIVATION_TRIGGER'
+ echo ' kernel option has wrong value'
+ echo ''
+ echo ' * Kernel version >=3.5 and <5.1 is required'
+ echo " Your version is $(uname -r)"
+ echo ' WARNING:'
+ echo ' Using the wrong version may render your system unbootable'
}
post_upgrade () {
- echo ' * Kernel version >=3.2 and <5.1 is required'
- echo " Your version is $(uname -r)"
- echo ' !! Using the wrong version may render your system unbootable'
+ echo ' * Kernel version >=3.5 and <5.1 is required'
+ echo " Your version is $(uname -r)"
+ echo ' WARNING:'
+ echo ' Using the wrong version may render your system unbootable'
}
+