summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Le Moal2019-10-08 10:58:13 +0200
committerOlivier Le Moal2019-10-08 10:58:13 +0200
commitb4892264bc7b2e3c4a124c7bed9d2cf72fb8a723 (patch)
treed9b43b0c35cbd0c72c923a0f795dda3e28511a9d
downloadaur-b4892264bc7b2e3c4a124c7bed9d2cf72fb8a723.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a8fb9de6a69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tonelib-zoom-bin
+ pkgdesc = ToneLib Zoom – change and save all the settings in your Zoom(r) guitar pedal
+ pkgver = 3.8.5
+ pkgrel = 1
+ url = https://tonelib.net/zoom-quick-start/
+ arch = x86_64
+ license = custom
+ depends = webkit2gtk
+ optdepends = jack: JACK output
+ source = https://www.tonelib.net/download/ToneLib-Zoom-amd64.deb
+ sha256sums = fed488890860327558200d5658d0d58782631e695d63d3ed7dbaa9b5e2b80c9c
+
+pkgname = tonelib-zoom-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fe6f3586f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: olivierlm < mail at olivierlemoal dot fr >
+
+pkgname=tonelib-zoom-bin
+pkgver=3.8.5
+pkgrel=1
+pkgdesc="ToneLib Zoom – change and save all the settings in your Zoom(r) guitar pedal"
+arch=('x86_64')
+license=('custom')
+url="https://tonelib.net/zoom-quick-start/"
+depends=('webkit2gtk')
+optdepends=('jack: JACK output')
+source=("https://www.tonelib.net/download/ToneLib-Zoom-amd64.deb")
+sha256sums=('fed488890860327558200d5658d0d58782631e695d63d3ed7dbaa9b5e2b80c9c')
+
+package () {
+ tar xf data.tar.xz -C "${pkgdir}"
+ install -D -m644 "${pkgdir}/usr/share/doc/tonelib-zoom/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+