summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-09-03 22:57:18 -0500
committerRiley Trautman2015-09-03 22:57:18 -0500
commit24e2cdf30b4c3755fa73d2da6fb7d4063e6fc1e1 (patch)
tree229f32f0d86e696954e348bb46372ff864457c31
downloadaur-24e2cdf30b4c3755fa73d2da6fb7d4063e6fc1e1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
-rw-r--r--qt.conf2
-rw-r--r--toontown-rewritten.desktop11
-rw-r--r--toontown-rewritten.sh6
5 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6ed41f43a70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = toontown-rewritten
+ pkgdesc = An MMO originally by Disney, rewritten. An account is needed to play.
+ pkgver = 1.2.0
+ pkgrel = 1
+ arch = x86_64
+ makedepends = git
+ depends = qt5-base
+ provides = toontown-rewritten
+ options = !strip
+ source = https://download.toontownrewritten.com/launcher/linux/TTRLinux-v1.2.0.tar.gz
+ source = qt.conf
+ source = toontown-rewritten.sh
+ source = toontown-rewritten.desktop
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = toontown-rewritten
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca5f694c560a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+
+pkgname=toontown-rewritten
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="An MMO originally by Disney, rewritten. An account is needed to play."
+arch=("x86_64")
+url=""
+license=("")
+depends=("qt5-base")
+makedepends=("git")
+provides=("$pkgname")
+source=("https://download.toontownrewritten.com/launcher/linux/TTRLinux-v$pkgver.tar.gz"
+ "qt.conf" "toontown-rewritten.sh" "toontown-rewritten.desktop")
+options=(!strip)
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP")
+
+package() {
+ mkdir -p "$pkgdir"/opt/toontown-rewritten
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/applications
+
+ install -m755 Toontown\ Rewritten/Launcher "$pkgdir"/opt/toontown-rewritten/Launcher
+ install qt.conf "$pkgdir"/opt/toontown-rewritten/qt.conf
+ install -m755 ../toontown-rewritten.sh "$pkgdir"/usr/bin/toontown-rewritten
+ install -m755 ../toontown-rewritten.desktop "$pkgdir"/usr/share/applications/toontown-rewritten.desktop
+}
diff --git a/qt.conf b/qt.conf
new file mode 100644
index 000000000000..1f0867f9cc05
--- /dev/null
+++ b/qt.conf
@@ -0,0 +1,2 @@
+[Paths]
+Libraries=''
diff --git a/toontown-rewritten.desktop b/toontown-rewritten.desktop
new file mode 100644
index 000000000000..3b20757b9bff
--- /dev/null
+++ b/toontown-rewritten.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Toontown Rewritten
+Comment=Play Toontown Rewritten
+Keywords=Game;entertainment;
+GenericName=Web Browser
+Exec=toontown-rewritten
+Icon=toontown
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Game;Entertainment;
diff --git a/toontown-rewritten.sh b/toontown-rewritten.sh
new file mode 100644
index 000000000000..efcb31f1bded
--- /dev/null
+++ b/toontown-rewritten.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+# Launch
+mkdir ~/.toontown-rewritten
+cd ~/.toontown-rewritten
+exec /opt/toontown-rewritten/Launcher