summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Plakhotniuk2015-06-23 15:38:05 -0500
committerOleg Plakhotniuk2015-06-23 15:38:05 -0500
commitc01b9b282557be321f3a438fe3c0a72972602a13 (patch)
treef5eebc355eb08a4b1ab837d035e2b5e231b0f787
downloadaur-c01b9b282557be321f3a438fe3c0a72972602a13.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rwxr-xr-xtoothris-run2
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71e1365585b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Thu Apr 9 00:41:58 UTC 2015
+pkgbase = toothris
+ pkgdesc = Smooth Tetris clone with a few surprises.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.toothris.org
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python2-pygame
+ depends = python2-pygame
+ depends = python2-opengl
+ depends = stackless-python2
+ depends = python-rabbyt
+ source = git+https://github.com/toothris/toothris#tag=1.0.0
+ source = toothris-run
+ md5sums = SKIP
+ md5sums = 6e159bf700c3a4d48d4bbc6ca8a16fa7
+
+pkgname = toothris
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43c5fb17925a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Oleg Plakhotniuk <olegus8@gmail.com>
+pkgname=toothris
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Smooth Tetris clone with a few surprises."
+arch=('any')
+url="http://www.toothris.org"
+license=('GPL3')
+depends=('python2-pygame' 'python2-opengl' 'stackless-python2' 'python-rabbyt')
+makedepends=('git' 'python2-pygame')
+source=("git+https://github.com/toothris/toothris#tag=${pkgver}"
+ "toothris-run")
+md5sums=('SKIP'
+ '6e159bf700c3a4d48d4bbc6ca8a16fa7')
+
+build() {
+ cd "$srcdir/$pkgname/src"
+ python2 packres.py
+ python2 -m compileall .
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir"/usr/{bin,lib/toothris}
+ cp "$srcdir/toothris-run" "$pkgdir/usr/bin/toothris"
+ cp -r src/*.pyc "$pkgdir/usr/lib/toothris"
+}
diff --git a/toothris-run b/toothris-run
new file mode 100755
index 000000000000..f431ee996b54
--- /dev/null
+++ b/toothris-run
@@ -0,0 +1,2 @@
+#!/bin/sh
+python2 /usr/lib/toothris/toothris.pyc "$@"