summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWesley Moore2019-10-16 13:11:49 +1100
committerWesley Moore2019-10-16 13:11:49 +1100
commit8e0f607f66da9ea5d91c51a35fbf3fd4bd489927 (patch)
treed619115c57c8f4fb4840e78aec923f082f2b3efc
parentf7621bcc8c308c50ef6accaab035899718e28835 (diff)
downloadaur-8e0f607f66da9ea5d91c51a35fbf3fd4bd489927.tar.gz
Fix build on Vala 0.46
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--fix-build-on-vala-46.patch23
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0f1bb5892c7..548e5a4208d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tootle
pkgdesc = GTK3 client for Mastodon
pkgver = 0.2.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/bleakgrey/tootle
arch = x86_64
license = GPL3
@@ -24,7 +24,9 @@ pkgbase = tootle
optdepends = noto-fonts-emoji: color emoji
options = !libtool
source = https://github.com/bleakgrey/tootle/archive/0.2.0.tar.gz
+ source = fix-build-on-vala-46.patch
sha256sums = e83c4a0539bf7b4b9d2b81d036ee0e8a69564b11c70f77ded5091955a89d2737
+ sha256sums = 5158d1e2019eaf6f4fa043b8483f8dfa049335d572a2563a0d4f71f799cae2b0
pkgname = tootle
diff --git a/PKGBUILD b/PKGBUILD
index 0818d3f11063..a3e0997a2551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=tootle
pkgver=0.2.0
-pkgrel=3
+pkgrel=4
pkgdesc="GTK3 client for Mastodon"
arch=('x86_64')
url="https://github.com/bleakgrey/tootle"
@@ -10,8 +10,15 @@ depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'libsoup' 'granite' 'json-glib')
optdepends=('noto-fonts-emoji: color emoji')
makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection' 'meson' 'ninja' 'vala')
options=('!libtool')
-source=("https://github.com/bleakgrey/$pkgname/archive/${pkgver//_/-}.tar.gz")
-sha256sums=('e83c4a0539bf7b4b9d2b81d036ee0e8a69564b11c70f77ded5091955a89d2737')
+source=("https://github.com/bleakgrey/$pkgname/archive/${pkgver//_/-}.tar.gz"
+ "fix-build-on-vala-46.patch")
+sha256sums=('e83c4a0539bf7b4b9d2b81d036ee0e8a69564b11c70f77ded5091955a89d2737'
+ '5158d1e2019eaf6f4fa043b8483f8dfa049335d572a2563a0d4f71f799cae2b0')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < ../fix-build-on-vala-46.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/fix-build-on-vala-46.patch b/fix-build-on-vala-46.patch
new file mode 100644
index 000000000000..543c9443b511
--- /dev/null
+++ b/fix-build-on-vala-46.patch
@@ -0,0 +1,23 @@
+From 0a88bdad6d969ead1e4058b1a19675c9d6857b16 Mon Sep 17 00:00:00 2001
+From: worldofpeace <worldofpeace@protonmail.ch>
+Date: Mon, 14 Oct 2019 16:44:16 -0400
+Subject: [PATCH] Fix build with vala 0.46
+
+See: https://gitlab.gnome.org/GNOME/vala/issues/766
+---
+ src/Views/AbstractView.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Views/AbstractView.vala b/src/Views/AbstractView.vala
+index e1c7f06..2945624 100644
+--- a/src/Views/AbstractView.vala
++++ b/src/Views/AbstractView.vala
+@@ -21,7 +21,7 @@ public abstract class Tootle.AbstractView : ScrolledWindow {
+ });
+ }
+
+- public AbstractView () {
++ protected AbstractView () {
+ show_all ();
+ }
+