summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Harmathy2022-06-16 12:58:53 +0200
committerMax Harmathy2022-06-16 13:08:38 +0200
commite94e27993d265d0b675db193bef1d80eca8b88f2 (patch)
treee599e7db1b77d9dd0f522cdecb5ab3af842f0830
parent4a5db56c6d68a35628f880843828601515a20643 (diff)
downloadaur-e94e27993d265d0b675db193bef1d80eca8b88f2.tar.gz
Fix build issues
Add patch by Çağatay Yiğit Şahin from https://github.com/flathub/com.github.bleakgrey.tootle/pull/22
-rw-r--r--.SRCINFO4
-rw-r--r--Fix-construct-prop.patch69
-rw-r--r--PKGBUILD7
3 files changed, 77 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 244338f5279d..f359d2ec5184 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tootle
pkgdesc = GTK3 client for Mastodon
pkgver = 1.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/bleakgrey/tootle
arch = x86_64
arch = aarch64
@@ -29,9 +29,11 @@ pkgbase = tootle
source = Use-reason_phrase-instead-of-get_phrase.patch
source = Adhere-to-GLib.Object-naming-conventions.patch
source = Application-make-app_entries-private.patch
+ source = Fix-construct-prop.patch
sha256sums = e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496
sha256sums = 06314649f967661defaf5d847a9ecdf4b942299a08613c4f3087afa6ecf5d7fc
sha256sums = 84962b788787c075fadaf2fe4e56f104340b6f1386c889df03455a67fcc5f779
sha256sums = 54baf63d378444e37a5bbfb8087fea5fc9c0bf90c67b0bde568b41c121f00660
+ sha256sums = cd8046061895ca86fcaf07c856366caf40c39f770e2522f9a1afb29a526618d0
pkgname = tootle
diff --git a/Fix-construct-prop.patch b/Fix-construct-prop.patch
new file mode 100644
index 000000000000..2432c03c28a9
--- /dev/null
+++ b/Fix-construct-prop.patch
@@ -0,0 +1,69 @@
+diff --git a/src/API/NotificationType.vala b/src/API/NotificationType.vala
+index c3f4420..15ba2ae 100644
+--- a/src/API/NotificationType.vala
++++ b/src/API/NotificationType.vala
+@@ -5,7 +5,8 @@ public enum Tootle.API.NotificationType {
+ FAVOURITE,
+ FOLLOW,
+ FOLLOW_REQUEST, // Internal
+- WATCHLIST; // Internal
++ WATCHLIST, // Internal
++ NONE; // Internal
+
+ public string to_string () {
+ switch (this) {
+diff --git a/src/Widgets/Notification.vala b/src/Widgets/Notification.vala
+index 3e2fe54..41ed71f 100644
+--- a/src/Widgets/Notification.vala
++++ b/src/Widgets/Notification.vala
+@@ -16,7 +16,7 @@ public class Tootle.Widgets.Notification : Widgets.Status {
+ }
+
+ protected override void on_kind_changed () {
+- if (kind == null)
++ if (kind == API.NotificationType.NONE)
+ return;
+
+ header_icon.visible = header_label.visible = true;
+diff --git a/src/Widgets/Status.vala b/src/Widgets/Status.vala
+index ef51340..ce1c951 100644
+--- a/src/Widgets/Status.vala
++++ b/src/Widgets/Status.vala
+@@ -5,7 +5,7 @@ using Gdk;
+ public class Tootle.Widgets.Status : ListBoxRow {
+
+ public API.Status status { get; construct set; }
+- public API.NotificationType? kind { get; construct set; }
++ public API.NotificationType kind { get; construct set; }
+
+ public enum ThreadRole {
+ NONE,
+@@ -113,7 +113,7 @@ public class Tootle.Widgets.Status : ListBoxRow {
+ notify["kind"].connect (on_kind_changed);
+ open.connect (on_open);
+
+- if (kind == null) {
++ if (kind == API.NotificationType.NONE) {
+ if (status.reblog != null)
+ kind = API.NotificationType.REBLOG_REMOTE_USER;
+ }
+@@ -164,7 +164,7 @@ public class Tootle.Widgets.Status : ListBoxRow {
+ menu_button.clicked.connect (open_menu);
+ }
+
+- public Status (owned API.Status status, API.NotificationType? kind = null) {
++ public Status (owned API.Status status, API.NotificationType kind = API.NotificationType.NONE) {
+ Object (
+ status: status,
+ kind: kind
+@@ -180,8 +180,8 @@ public class Tootle.Widgets.Status : ListBoxRow {
+ }
+
+ protected virtual void on_kind_changed () {
+- header_icon.visible = header_label.visible = (kind != null);
+- if (kind == null)
++ header_icon.visible = header_label.visible = (kind != API.NotificationType.NONE);
++ if (kind == API.NotificationType.NONE)
+ return;
+
+ header_icon.icon_name = kind.get_icon ();
diff --git a/PKGBUILD b/PKGBUILD
index 88d08ddc6504..946e415fc539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=tootle
pkgver=1.0
_pkgver=${pkgver//_/-}
-pkgrel=6
+pkgrel=7
pkgdesc="GTK3 client for Mastodon"
arch=('x86_64' 'aarch64')
url="https://github.com/bleakgrey/tootle"
@@ -38,11 +38,13 @@ source=(
"Use-reason_phrase-instead-of-get_phrase.patch"
"Adhere-to-GLib.Object-naming-conventions.patch"
"Application-make-app_entries-private.patch"
+ "Fix-construct-prop.patch"
)
sha256sums=('e0a0a062b1b72010242f7bb4db97cd71190f23067188b5c07372264d768a0496'
'06314649f967661defaf5d847a9ecdf4b942299a08613c4f3087afa6ecf5d7fc'
'84962b788787c075fadaf2fe4e56f104340b6f1386c889df03455a67fcc5f779'
- '54baf63d378444e37a5bbfb8087fea5fc9c0bf90c67b0bde568b41c121f00660')
+ '54baf63d378444e37a5bbfb8087fea5fc9c0bf90c67b0bde568b41c121f00660'
+ 'cd8046061895ca86fcaf07c856366caf40c39f770e2522f9a1afb29a526618d0')
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
@@ -50,6 +52,7 @@ build() {
patch -p1 < "$startdir/Use-reason_phrase-instead-of-get_phrase.patch"
patch -p1 < "$startdir/Adhere-to-GLib.Object-naming-conventions.patch"
patch -p1 < "$startdir/Application-make-app_entries-private.patch"
+ patch -p1 < "$startdir/Fix-construct-prop.patch"
arch-meson build
ninja -C build