summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDani Rodríguez2024-02-19 08:50:34 +0100
committerDani Rodríguez2024-02-19 08:50:34 +0100
commit84a82fd076e1207b4914ddf2d6c27f8617e98f51 (patch)
treeddeb338e74d32d26bc38f53ec6c2c6724e67606f
parentfad391215c4e17dfff07ea438b337e08180c4351 (diff)
downloadaur-84a82fd076e1207b4914ddf2d6c27f8617e98f51.tar.gz
Bump to tootstream 0.4.0
Bumps PKGBUILD to 0.4.0, the latest released and numbered version of this package. A patch is provided to fix the runtime errors introduced by a breaking change in an upstream dependency. Patch is taken from commit 32041df30c838a75bc2863a36eb1442bfaba3e70 from the tootstream repository. (See https://github.com/magicalraccoon/tootstream/issues/231). Aside from that, no other commits are cherry-picked (that's the purpose of tootstream-git, which is the Git tip). The package currently compiles, sometimes shows a warning about using a deprecated setup.py build command, but these are part of the build instructions of the upstream repository so I am not touching that. Also updates SRCINFO and moves former maintainers as contributors.
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Fix-for-later-versions-of-colored.patch46
-rw-r--r--PKGBUILD18
-rw-r--r--requirements.txt.patch4
4 files changed, 61 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00fccd400ed5..54492b4ea79c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tootstream
pkgdesc = Text interface for the Mastodon social network
- pkgver = 0.3.8.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/magicalraccoon/tootstream
arch = any
@@ -11,10 +11,9 @@ pkgbase = tootstream
depends = python-click
depends = python-colored
depends = python-emoji
- source = requirements.txt.patch
- source = tootstream-0.3.8.1.tar.gz::https://files.pythonhosted.org/packages/source/t/tootstream/tootstream-0.3.8.1.tar.gz
- sha256sums = 9ca9c83eada78ee42f011c6e3bd8e5b01caf770b1c3b152238a8e13ff26138d6
- sha256sums = 69886966c98d6fdbf051958832f80c2b5364393796f42f011083ee25fc5ab7f8
+ source = tootstream-0.4.0.tar.gz::https://files.pythonhosted.org/packages/source/t/tootstream/tootstream-0.4.0.tar.gz
+ source = 0001-Fix-for-later-versions-of-colored.patch
+ sha256sums = ae30d2cec798d9b72eed378c5181c00cf3a5177ab09bb71fd6e4e20f9f860c93
+ sha256sums = e2fe90e24b1ddcb6f20d7d6bbda2b89871188ae65317d6d0952f1c8fe3bc44ee
pkgname = tootstream
-
diff --git a/0001-Fix-for-later-versions-of-colored.patch b/0001-Fix-for-later-versions-of-colored.patch
new file mode 100644
index 000000000000..423464bbda33
--- /dev/null
+++ b/0001-Fix-for-later-versions-of-colored.patch
@@ -0,0 +1,46 @@
+From 32041df30c838a75bc2863a36eb1442bfaba3e70 Mon Sep 17 00:00:00 2001
+From: Craig Maloney <craig@decafbad.net>
+Date: Wed, 30 Aug 2023 11:21:44 -0400
+Subject: [PATCH] Fix for later versions of colored to use underline instead of
+ underlined
+
+---
+ src/tootstream/toot.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/tootstream/toot.py b/src/tootstream/toot.py
+index 941dcf2..a41a3c1 100644
+--- a/src/tootstream/toot.py
++++ b/src/tootstream/toot.py
+@@ -1053,7 +1053,7 @@ def help(mastodon, rest):
+ if new_section:
+ cprint(
+ "{section}:".format(section=section),
+- fg("white") + attr("bold") + attr("underlined"),
++ fg("white") + attr("bold") + attr("underline"),
+ )
+ new_section = False
+
+@@ -1104,11 +1104,11 @@ def toot(mastodon, rest):
+ cprint("You tooted: ", fg("white") + attr("bold"), end="\n")
+ if resp["sensitive"]:
+ cprint("CW: " + resp["spoiler_text"], fg("red"))
+- cprint(text, fg("magenta") + attr("bold") + attr("underlined"))
++ cprint(text, fg("magenta") + attr("bold") + attr("underline"))
+ posted = True
+ except Exception as e:
+ cprint("Received error: ", fg("red") + attr("bold"), end="")
+- cprint(e, fg("magenta") + attr("bold") + attr("underlined"))
++ cprint(e, fg("magenta") + attr("bold") + attr("underline"))
+
+ # If we're streaming then we can't edit the toot, so assume that we posted.
+ if is_streaming is True:
+@@ -1271,7 +1271,7 @@ def boost(mastodon, rest):
+ cprint(msg, attr("dim"))
+ except Exception as e:
+ cprint("Received error: ", fg("red") + attr("bold"), end="")
+- cprint(e, fg("magenta") + attr("bold") + attr("underlined"))
++ cprint(e, fg("magenta") + attr("bold") + attr("underline"))
+
+
+ @command("<id>", "Toots")
diff --git a/PKGBUILD b/PKGBUILD
index 7aaa58fd85b7..0b3c8b389283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Marc Grondin <myself AT marcg DOT pizza>
-# Maintainer: Daniel Moch <daniel AT danielmoch DOT com>
+# Maintainer: Dani Rodríguez <dani@danirod.es>
+# Contributor: Marc Grondin <myself AT marcg DOT pizza>
+# Contributor: Daniel Moch <daniel AT danielmoch DOT com>
# Contributor: Drew DeVault <sir@cmpwn.com>
pkgname=tootstream
-pkgver=0.3.8.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="Text interface for the Mastodon social network"
arch=(any)
@@ -14,13 +15,14 @@ depends=(python-mastodon
python-colored
python-emoji)
makedepends=(python-distribute)
-source=("requirements.txt.patch"
- "${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9ca9c83eada78ee42f011c6e3bd8e5b01caf770b1c3b152238a8e13ff26138d6'
- '69886966c98d6fdbf051958832f80c2b5364393796f42f011083ee25fc5ab7f8')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "0001-Fix-for-later-versions-of-colored.patch")
+sha256sums=('ae30d2cec798d9b72eed378c5181c00cf3a5177ab09bb71fd6e4e20f9f860c93'
+ 'e2fe90e24b1ddcb6f20d7d6bbda2b89871188ae65317d6d0952f1c8fe3bc44ee')
prepare() {
- patch ${pkgname}-${pkgver}/requirements.txt requirements.txt.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -s < "${srcdir}/0001-Fix-for-later-versions-of-colored.patch"
}
build() {
diff --git a/requirements.txt.patch b/requirements.txt.patch
deleted file mode 100644
index 0e183b9e7a2a..000000000000
--- a/requirements.txt.patch
+++ /dev/null
@@ -1,4 +0,0 @@
-2c2
-< Mastodon.py==1.5.0
----
-> Mastodon.py>=1.5.0