summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-07-23 21:06:47 -0400
committerDaniel Moch2018-07-23 21:14:11 -0400
commitf4a1cc5a394c64f46d1bb1db5a7ee29eb958c0a3 (patch)
treeedf13217b8f3ca36a86fc921eab6a3eeca7aefdf
downloadaur-f4a1cc5a394c64f46d1bb1db5a7ee29eb958c0a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9e6088fae96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tootstream-git
+ pkgdesc = Text interface for the Mastodon social network
+ pkgver = 0.3.4.r3.gfef1e72
+ pkgrel = 1
+ url = https://github.com/magicalraccoon/tootstream
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ makedepends = git
+ depends = python-mastodon
+ depends = python-humanize
+ depends = python-click
+ depends = python-colored
+ depends = python-emoji
+ provides = tootstream
+ conflicts = tootstream
+ source = git://github.com/magicalraccoon/tootstream.git
+ sha512sums = SKIP
+
+pkgname = tootstream-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..df0df3898bb0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
+tootstream/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8144f12a0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Moch <daniel@danielmoch.com>
+# Contributor: Drew DeVault <sir@cmpwn.com>
+_pkgname=tootstream
+pkgname=tootstream-git
+pkgver=0.3.4.r3.gfef1e72
+pkgrel=1
+pkgdesc='Text interface for the Mastodon social network'
+provides=('tootstream')
+conflicts=('tootstream')
+arch=('any')
+url='https://github.com/magicalraccoon/tootstream'
+license=('MIT')
+depends=(
+ 'python-mastodon'
+ 'python-humanize'
+ 'python-click'
+ 'python-colored'
+ 'python-emoji'
+)
+makedepends=('python-distribute' 'git')
+source=("git://github.com/magicalraccoon/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}