summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:38:48 +0200
committerL.G. Sarmiento2015-06-14 19:38:48 +0200
commit2ff4d397ec2085fbcef934f283becdd4fe5fd1b7 (patch)
treebe3efd49398b764ac23ec65b1c22858b0d70d790
downloadaur-2ff4d397ec2085fbcef934f283becdd4fe5fd1b7.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72d70f2ca81e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = top-c
+ pkgdesc = A Package for Easily Writing Parallel Applications for both Distributed and Shared Memory Architectures
+ pkgver = 2.5.2
+ pkgrel = 1
+ url = http://www.ccs.neu.edu/home/gene/topc.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ source = ftp://ftp.ccs.neu.edu/pub/people/gene/topc/topc.tar.gz
+ md5sums = d92435bcd977265d18bd1845758645ee
+
+pkgname = top-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaf285356998
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop@nuclear.lu.se>
+pkgname=top-c
+_pkgname=topc
+pkgver=2.5.2
+pkgrel=1
+pkgdesc="A Package for Easily Writing Parallel Applications for both Distributed and Shared Memory Architectures"
+url="http://www.ccs.neu.edu/home/gene/topc.html"
+arch=('i686' 'x86_64')
+license=('LGPL')
+source=(ftp://ftp.ccs.neu.edu/pub/people/gene/$_pkgname/$_pkgname.tar.gz)
+md5sums=('d92435bcd977265d18bd1845758645ee')
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+
+ msg "Tweaking the Makefile for installation"
+ sed -i 's#prefix=/usr#prefix=${DESTDIR}/usr#g' Makefile
+ sed -i "/&&/d" Makefile
+ sed -i "/install-info/d" Makefile
+ make DESTDIR=$pkgdir install
+}