summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-01-04 11:48:12 +0100
committerjose17112017-01-04 11:48:12 +0100
commitf3f1fd03affccb02f7a58e4ecc7c05042f8f0b78 (patch)
tree57b27f0ef1e5dff2a27f506c8cdde93266bee8e2
downloadaur-f3f1fd03affccb02f7a58e4ecc7c05042f8f0b78.tar.gz
Adopted from aur3-mirror and updated
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD49
-rw-r--r--topal.install19
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a25bbc598016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Jan 4 10:48:04 UTC 2017
+pkgbase = topal
+ pkgdesc = Topal is a glue program that links GnuPG and Alpine
+ pkgver = 76
+ pkgrel = 1
+ install = topal.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc-ada
+ makedepends = make
+ makedepends = lynx
+ optdepends = alpine: for which topal was mainly written for
+ optdepends = re-alpine: fork of alpine for which topal was mainly written for
+ optdepends = gnupg: to encrypt, decrypt, sign and verify e-mail
+ optdepends = metamail: to display and process MIME messages
+ optdepends = mime-support: its run-mailcap tool as alternative to metamail
+ optdepends = openssh: for remote and server mode of operation
+ options = !makeflags
+ source = https://fossies.org/linux/privat/topal-package-76.tgz
+ md5sums = afe0010716bcb0073d31b3328c7b65ae
+
+pkgname = topal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a7df6305200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# adopted from aur3 mirror
+#
+# Contributor: Adrian C. (anrxc) <anrxc..sysphere.org>
+# Maintainer: Jose Riha jose1711 gmail com
+
+pkgname=topal
+pkgver=76
+pkgrel=1
+pkgdesc="Topal is a glue program that links GnuPG and Alpine"
+arch=("i686" "x86_64")
+#url="http://homepage.ntlworld.com/phil.brooke/topal"
+license=("GPL3")
+makedepends=("gcc-ada" "make" "lynx")
+optdepends=("alpine: for which topal was mainly written for"
+ "re-alpine: fork of alpine for which topal was mainly written for"
+ "gnupg: to encrypt, decrypt, sign and verify e-mail"
+ "metamail: to display and process MIME messages"
+ "mime-support: its run-mailcap tool as alternative to metamail"
+ "openssh: for remote and server mode of operation")
+install="${pkgname}.install"
+options=("!makeflags")
+source=("https://fossies.org/linux/privat/topal-package-${pkgver}.tgz")
+md5sums=('afe0010716bcb0073d31b3328c7b65ae')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+# Remove PDF build stuff
+ sed -i 's/binary topal.pdf/binary/' Makefile
+
+# Build Topal and MIME-tool
+ make distclean
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+# Install Topal binary, manual page and documentation
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "${pkgname}.man" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+# Replaced by some PDF stuff which we will not build
+ #install -D -m644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README"
+
+# Install Topal's version of MIME-tool and manual page
+ install -D -m755 MIME-tool/mime-tool "${pkgdir}/usr/bin/mime-tool"
+ install -D -m644 MIME-tool/mime-tool.man "${pkgdir}/usr/share/man/man1/mime-tool.1"
+}
diff --git a/topal.install b/topal.install
new file mode 100644
index 000000000000..a531234c85f4
--- /dev/null
+++ b/topal.install
@@ -0,0 +1,19 @@
+post_install() {
+cat << _EOF
+
+==> topal installation notes:
+ ----------------------------------------
+ Topal was mainly developed for the Alpine mailer, and it offers
+ facilities to encrypt, decrypt, sign and verify e-mail. But Alpine
+ can't work with MIME RFC2015/3156 multipart/signed and encrypted
+ messages on its own. If you would like to have multipart e-mail
+ support check both "alpine-2.00" patches provided in the topal
+ tarball and build your own alpine package applying both.
+
+_EOF
+
+}
+
+post_upgrade() {
+ post_install
+}