summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Joost2020-12-16 10:09:54 +0100
committerPieter Joost2020-12-16 10:10:10 +0100
commit0896db82dd6e1cbb92dc527d55aa5ae9b5528a0e (patch)
treea9f31aa89c19a7dc332e7d353fac5887d97e6a36
downloadaur-0896db82dd6e1cbb92dc527d55aa5ae9b5528a0e.tar.gz
initial release 2.0.14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3852d4dc98f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = topalias
+ pkgdesc = Linux bash/zsh alias generator and statistics from command history,
+ pkgver = 2.0.14
+ pkgrel = 1
+ url = https://github.com/CSRedRat/topalias
+ arch = any
+ license = GNU
+ makedepends = python-setuptools
+ depends = python3
+ source = https://github.com/CSRedRat/topalias/archive/v2.0.14.tar.gz
+ sha512sums = ba04c98d57101e7f8c184c1afe1e95ab561e95499d652726ab512bbb1e2d6525d700f2a14ddbe3c0f07f130f23bf73410436cab0cec12e37a1ffbf325ee5012a
+
+pkgname = topalias
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8810960b0629
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pieter Joost <pj@born2code.net>
+pkgname=topalias
+pkgver=2.0.14
+pkgrel=1
+pkgdesc="Linux bash/zsh alias generator and statistics from command history,"
+arch=('any')
+url="https://github.com/CSRedRat/topalias"
+license=('GNU')
+depends=('python3')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('ba04c98d57101e7f8c184c1afe1e95ab561e95499d652726ab512bbb1e2d6525d700f2a14ddbe3c0f07f130f23bf73410436cab0cec12e37a1ffbf325ee5012a')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root="${pkgdir}"
+}
+
+install() {
+ install -Dm 644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
+}