summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Langlois2015-09-29 14:36:09 +0200
committerTyler Langlois2015-09-29 14:36:09 +0200
commit88db1fb9c4c1653c4ddbf33cc08add278613fb25 (patch)
tree645cccdd19ed0cf1f11b5553da9decb8f43c0586
downloadaur-88db1fb9c4c1653c4ddbf33cc08add278613fb25.tar.gz
topbeat-bin: create package
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
-rw-r--r--topbeat.service9
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dc595203d88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = topbeat-bin
+ pkgdesc = An open source server monitoring agent that stores metrics in Elasticsearch (precompiled)
+ pkgver = 1.0.0_beta3
+ pkgrel = 1
+ url = https://www.elastic.co/products/beats
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ optdepends = elasticsearch: for running standalone installation
+ provides = topbeat
+ conflicts = topbeat
+ options = !strip
+ backup = etc/topbeat/topbeat.yml
+ source = topbeat.service
+ sha256sums = 62f5b613d9464e4d8b1074c1a54b95cbd1c6615f0c788f1d9093becbdbc6c45d
+ source_i686 = https://download.elastic.co/beats/topbeat/topbeat-1.0.0-beta3-i686.tar.gz
+ sha256sums_i686 = e3a7772b7eb25cb3627b29acc61e3d874dbae6aef0b6e1c5648ebe376d6b89ee
+ source_x86_64 = https://download.elastic.co/beats/topbeat/topbeat-1.0.0-beta3-x86_64.tar.gz
+ sha256sums_x86_64 = 42a8ab17f9638eb62397f79b21198763cc8c8c26370c615047a4656df624409c
+
+pkgname = topbeat-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59404bda5d0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tyler Langlois <ty |at| tjll |dot| net>
+
+pkgname=topbeat-bin
+_pkgbase=${pkgname%%-bin}
+pkgver=1.0.0_beta3
+_pkgver=${pkgver/_/-}
+pkgrel=1
+pkgdesc='An open source server monitoring agent that stores metrics in Elasticsearch (precompiled)'
+arch=('i686' 'x86_64')
+url="https://www.elastic.co/products/beats"
+license=('APACHE')
+backup=("etc/$_pkgbase/$_pkgbase.yml")
+optdepends=('elasticsearch: for running standalone installation')
+options=('!strip')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
+source=("$_pkgbase.service")
+sha256sums=('62f5b613d9464e4d8b1074c1a54b95cbd1c6615f0c788f1d9093becbdbc6c45d')
+
+source_i686=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-i686.tar.gz")
+source_x86_64=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$_pkgver-x86_64.tar.gz")
+sha256sums_i686=('e3a7772b7eb25cb3627b29acc61e3d874dbae6aef0b6e1c5648ebe376d6b89ee')
+sha256sums_x86_64=('42a8ab17f9638eb62397f79b21198763cc8c8c26370c615047a4656df624409c')
+
+package() {
+ cd "$srcdir/$_pkgbase-$_pkgver-$CARCH"
+
+ install -D -m755 $_pkgbase "$pkgdir/usr/bin/$_pkgbase"
+ install -D -m644 $_pkgbase.yml "$pkgdir/etc/$_pkgbase/$_pkgbase.yml"
+ install -D -m644 $_pkgbase.template.json \
+ "$pkgdir/etc/$_pkgbase/$_pkgbase.template.json"
+
+ install -D -m644 "$srcdir/$_pkgbase.service" \
+ "$pkgdir/usr/lib/systemd/system/$_pkgbase.service"
+}
diff --git a/topbeat.service b/topbeat.service
new file mode 100644
index 000000000000..d4c4419e26ce
--- /dev/null
+++ b/topbeat.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=open source server monitoring agent that stores metrics in Elasticsearch
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/topbeat -c /etc/topbeat/topbeat.yml
+
+[Install]
+WantedBy=multi-user.target