summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoushik Sahu2022-06-04 12:55:50 +0530
committerKoushik Sahu2022-06-04 12:55:50 +0530
commit9adaec69c1a2a7a1de17a7dd7367cb3a94df8d41 (patch)
treeaef71950cfd52f542c1cea2c13fc46cbdc796d12
parent978d9f9d03bad465a68edb8da4f9e1e365a28bcf (diff)
downloadaur-9adaec69c1a2a7a1de17a7dd7367cb3a94df8d41.tar.gz
fix directory structure, fix desktop file, add md5 sums
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--topcoder-applet.desktop14
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c1e371e1a73..6bcef7ba32ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,9 +10,9 @@ pkgbase = topcoder-applet
source = topcoder_logo.png
source = topcoder-applet.desktop
source = exception.sites
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = 938ae37090f43dfc69ffe03efddf6f5c
+ md5sums = e678ae8884b6b3a0d3a4fc4539b26a50
+ md5sums = 24f7a3136e9aa46353a26c1cbf8d6a30
+ md5sums = 49169bb9782db7bd1b3748e30952a720
pkgname = topcoder-applet
diff --git a/PKGBUILD b/PKGBUILD
index ecd2ce5657e7..179a82a9699b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
-# Maintainer: Your Name <youremail@domain.com>
+# Maintainer: Koushik Sahu <koushiksahu68@gmail.com>
pkgname=topcoder-applet
pkgver=1.0
pkgrel=1
@@ -29,19 +29,23 @@ source=("http://topcoder.com/contest/arena/ContestAppletProd7.2.jnlp"
"topcoder-applet.desktop"
"exception.sites")
noextract=()
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+md5sums=('938ae37090f43dfc69ffe03efddf6f5c' 'e678ae8884b6b3a0d3a4fc4539b26a50' '24f7a3136e9aa46353a26c1cbf8d6a30' '49169bb9782db7bd1b3748e30952a720')
validpgpkeys=()
programname="ContestAppletProd7.2.jnlp"
logoname="topcoder_logo.png"
desktopname="topcoder-applet.desktop"
package() {
- mkdir -p $pkgdir/usr/bin/topcoder
- mkdir -p $pkgdir/usr/share/applications
+ mkdir -p $pkgdir/usr/local/topcoder
+ mkdir -p $pkgdir/.local/share/applications
mkdir -p $pkgdir$HOME/.java/deployment/security
- cp $programname $pkgdir/usr/bin/topcoder/$programname
- cp $logoname $pkgdir/usr/bin/topcoder/$logoname
- cp $desktopname $pkgdir/usr/share/applications
+
+ cp $programname $pkgdir/usr/local/topcoder
+ cp $logoname $pkgdir/usr/local/topcoder
+
+ cp $desktopname $pkgdir/.local/share/applications
+ chmod +x $pkgdir/.local/share/applications/$desktopname
+
cp exception.sites $pkgdir$HOME/.java/deployment/security
}
diff --git a/topcoder-applet.desktop b/topcoder-applet.desktop
index b64e08f963df..411528e44139 100644
--- a/topcoder-applet.desktop
+++ b/topcoder-applet.desktop
@@ -1,13 +1,9 @@
[Desktop Entry]
Type=Application
-Name[en_US.UTF-8]=Topcoder Applet
-X-GNOME-FullName[en_US.UTF-8]=Topcoder Applet
-Comment[en_US.UTF-8]=
-Icon=/usr/bin/topcoder/topcoder_logo.png
-NoDisplay=false
-Exec=javaws ContestAppletProd7.2.jnlp
-Path=/usr/bin/topcoder
+Name=Topcoder Applet
+Comment=Topcoder applet for participating and practicing on topcoder competitive programming events
+Exec=javaws /usr/local/topcoder/ContestAppletProd7.2.jnlp
+Icon=/usr/local/topcoder/topcoder_logo.png
Terminal=false
-X-GNOME-UsesNotifications=true
-Categories=Development;
+Categories=Education;