summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2016-03-23 14:58:16 +0100
committerChristian Krause2016-03-23 14:58:16 +0100
commit1058cf08d5e6449bf7bf9d4b44b3e0883169d069 (patch)
tree5fde5d7d870a56f914aeec6caa71da2061eeefa5
parent80af243f377cb9d7af89d5bdd2b50765a6cb0474 (diff)
downloadaur-1058cf08d5e6449bf7bf9d4b44b3e0883169d069.tar.gz
tophat-2.1.1-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--fix_build_w_seqan1.4.patch23
3 files changed, 12 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0143b0049164..21a3b1b71a3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Mar 23 13:58:02 UTC 2016
pkgbase = tophat
pkgdesc = fast splice junction mapper for RNA-Seq reads
- pkgver = 2.1.0
- pkgrel = 3
+ pkgver = 2.1.1
+ pkgrel = 1
url = http://ccb.jhu.edu/software/tophat/index.shtml
arch = x86_64
arch = i686
@@ -10,12 +12,8 @@ pkgbase = tophat
depends = boost-libs
depends = bowtie2
depends = python2
- source = http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.0.tar.gz
- source = https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz
- source = fix_build_w_seqan1.4.patch
- md5sums = 34afa379b030c6672a31bbe3689745bc
- md5sums = 7b0080b01feeb223e054dabef53d6fc5
- md5sums = 93d47e54408b7b5eb4132d65f5dd5085
+ source = http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.1.tar.gz
+ md5sums = 4b2391de46457ba6b2b7268a9da593e4
pkgname = tophat
diff --git a/PKGBUILD b/PKGBUILD
index 9494bceb596f..b7d6a6d65104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,20 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=tophat
-pkgver=2.1.0
-pkgrel=3
+pkgver=2.1.1
+pkgrel=1
pkgdesc="fast splice junction mapper for RNA-Seq reads"
arch=('x86_64' 'i686')
url="http://ccb.jhu.edu/software/tophat/index.shtml"
license=('custom')
depends=('boost-libs' 'bowtie2' 'python2')
makedepends=('boost')
-source=("http://ccb.jhu.edu/software/tophat/downloads/tophat-$pkgver.tar.gz"
- 'https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz'
- 'fix_build_w_seqan1.4.patch')
-md5sums=('34afa379b030c6672a31bbe3689745bc'
- '7b0080b01feeb223e054dabef53d6fc5'
- '93d47e54408b7b5eb4132d65f5dd5085')
+source=("http://ccb.jhu.edu/software/tophat/downloads/tophat-$pkgver.tar.gz")
+md5sums=('4b2391de46457ba6b2b7268a9da593e4')
prepare() {
cd $srcdir/$pkgname-$pkgver
- sed -e 's|-gdwarf-2||' \
- -e '/define.*esyscmd/d' \
- -e 's/svnversion/Unversioned directory/' \
- -i configure.ac
-
sed -e 's|make $(SAMPROG)|make -e $(SAMPROG)|' \
-i src/Makefile.am
@@ -31,16 +22,8 @@ prepare() {
-i src/bed_to_juncs \
src/contig_to_chr_coords \
src/sra_to_solid \
- src/tophat.py \
- src/tophat-fusion-post
-
- # fixes seqan issues
- rm -rf src/SeqAn-1.3
- patch -Np1 -i $srcdir/fix_build_w_seqan1.4.patch
- sed -e "s|-I./SeqAn-1.3|-I$srcdir/seqan-seqan-v1.4.2/core/include|" \
- -i configure.ac
-
- autoreconf -fi
+ src/tophat-fusion-post \
+ src/tophat.py
}
build() {
diff --git a/fix_build_w_seqan1.4.patch b/fix_build_w_seqan1.4.patch
deleted file mode 100644
index 7ab7c5af4a78..000000000000
--- a/fix_build_w_seqan1.4.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Description: Resolves build failure with seqan 1.4
-Bug-Closed: http://bugs.debian.org/733352
-Author: Manuel Holtgrewe <manuel.holtgrewe@fu-berlin.de>
---- a/src/segment_juncs.cpp
-+++ b/src/segment_juncs.cpp
-@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
- typedef map<uint32_t, IntronMotifs> MotifMap;
-
- MotifMap ims;
--
-- seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
-- seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
--
-+
-+ typedef seqan::ModifiedString<
-+ seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
-+ seqan::ModReverse> ConstDnaStringReverseComplement;
-+ ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
-+ ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
-+
- if (talkative)
- fprintf(stderr, "Collecting potential splice sites in islands\n");
-